Bug 828673 - abrt missing dependency: libreport-plugin-bugzilla
Summary: abrt missing dependency: libreport-plugin-bugzilla
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: abrt
Version: 6.3
Hardware: Unspecified
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Denys Vlasenko
QA Contact: Branislav Náter
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-05 07:37 UTC by Patrik Kis
Modified: 2013-02-21 07:53 UTC (History)
8 users (show)

Fixed In Version: abrt-2.0.8-7.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 07:53:48 UTC
Target Upstream Version:


Attachments (Terms of Use)
abrt screenshot (38.04 KB, image/png)
2012-06-05 07:37 UTC, Patrik Kis
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0290 normal SHIPPED_LIVE abrt, libreport and btparser bug fix and enhancement update 2013-02-20 20:55:47 UTC

Description Patrik Kis 2012-06-05 07:37:04 UTC
Created attachment 589423 [details]
abrt screenshot

Description of problem:
abrt does not depends on libreport-plugin-bugzilla, however in requires it

Version-Release number of selected component (if applicable):
abrt-2.0.8-6.el6.x86_64

How reproducible:
I did it once and then abrt did not give me the same possibilities.

Steps to Reproduce:
1. Tried to report the bug 828666 with abrt
2. In certain step abrt asked for something like "analyse locally" or similar (I was not able to return to this point)
3. In next window it said:
Analyzing finished with exit code 127

--- Running analyze_LocalGDB ---
Analyzing coredump 'coredump'
Generating backtrace
Backtrace is generated and saved, 17003 bytes
/bin/sh: line 4: reporter-bugzilla: command not found
(exited with 127)

The screenshot is attached.

4. When tried to report the same problem once again, abrt did not gave the same option.
  
Actual results:
abrt failed to report
Rerun seems help, but not with the same options.

Expected results:
No problems in reporting.

Additional info:

Comment 1 RHEL Program Management 2012-07-10 06:45:37 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 2 RHEL Program Management 2012-07-10 23:03:22 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 3 Denys Vlasenko 2012-07-29 19:55:56 UTC
Fixed in git:

commit c0e626795fa8f91b154338112de6fb7b4095fc79
Author: Denys Vlasenko <vda.linux@googlemail.com>
Date:   Sun Jul 29 21:54:29 2012 +0200

    abrt.spec: add missing dependencies for tools we run from default cfgs

Comment 5 Denys Vlasenko 2012-07-30 10:43:41 UTC
Reverted.

Comment 6 Denys Vlasenko 2012-07-31 15:19:01 UTC
Fixed in git:

commit 993d8a66e6fa1200eea3b5549a5f47ff81e85ed4
Author: Denys Vlasenko <vda.linux@googlemail.com>
Date:   Tue Jul 31 16:50:36 2012 +0200

    For RHEL, commenting out all reporter events for all types of problems

Comment 9 Branislav Náter 2013-01-09 15:50:42 UTC
Bugfix has been verified on abrt-2.0.8-9.el6.x86_64 and libreport-2.0.9-11.el6.x86_64 packages.

Verified by
- diff of old and new config files (reporter-bugzilla and bodhi have been commented out)
- all other scripts called from event configuration files are present in default installation
- reporting actual problem without any issue

Comment 10 Jiri Moskovcak 2013-01-24 15:08:45 UTC
Cause

Consequence

Fix
Result

- the same as 815339

Comment 11 errata-xmlrpc 2013-02-21 07:53:48 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0290.html


Note You need to log in before you can comment on or make changes to this bug.