Bug 82868 - Digital USB-connected camera Kodak EasyShare CX4300 not detected
Digital USB-connected camera Kodak EasyShare CX4300 not detected
Status: CLOSED NOTABUG
Product: Red Hat Public Beta
Classification: Retired
Component: kernel (Show other bugs)
phoebe
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Pete Zaitcev
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-27 17:59 EST by Simen E. Sandberg
Modified: 2007-04-18 12:50 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-02-03 17:59:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Simen E. Sandberg 2003-01-27 17:59:57 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 Galeon/1.2.7 (X11; Linux i686; U;) Gecko/20021216

Kernel: 2.4.20-2.24 i686
Red Hat Linux release 8.0.93 (Phoebe)

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Start computer
2. Plug in digital camera
3. Turn on digital camera

    

Actual Results:
usb.c: USB device 3 (vend/prod 0x40a/0x566) is not claimed by any active driver.
(from dmesg)

Expected Results:  Should be detected so gphoto2 (manually updated) could access
it. This worked fine with the latest 7.3-kernel, but not with 2.4.20-2.24.

Additional info:

The version of gphoto2 that is included can not access this camera, but version
2.1.1 can. This worked perfectly with 7.3, but not in this version.
Comment 1 Pete Zaitcev 2003-02-03 16:43:47 EST
Just in case, please do "ps aux| grep khubd" with the failing case.
The 2.4.20-2.24 should have the fix which practically disabled whole
USB in first Phoebe, but let's be sure.

Also, I would like /proc/bus/usb/devices attached to the bug.

The last thing, please never say "latest 7.3 kernel", that's not very
useful when we have uncertainties. I need actual version (2.4.18-19.7.x,
for instance) to reduce the uncertainty. In other words, this is what
I'll use to run diff -ur. It probably cannot be fixed now, but all the same...
Thought to let you know.
Comment 2 Simen E. Sandberg 2003-02-03 17:59:01 EST
I'm terribly sorry... When I had gathered the information you requested, I just
downloaded and reinstalled gphoto2 once more, and everything suddenly worked!
This should not be a bug at all. I'm sorry I reported it. The real bug is bug
81663, closed/wontfix. 

I still get the same error messages, but that is not a bug if Gphoto2 can access
the camera. I probably got the same error messages with 2.4.18-7.x (yes, it was
that version), but since it worked, I didn't notice.

Note You need to log in before you can comment on or make changes to this bug.