Bug 82870 - can't go switch back to us english after switching to french
can't go switch back to us english after switching to french
Status: CLOSED CANTFIX
Product: Red Hat Linux
Classification: Retired
Component: kde-i18n (Show other bugs)
8.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Petr Rockai
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-01-27 18:11 EST by khalid
Modified: 2007-04-18 12:50 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-10-18 14:25:48 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description khalid 2003-01-27 18:11:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr-FR; rv:1.0.2) Gecko/20021120
Netscape/7.01

Description of problem:
After intstalling kde-i18n-French-3.0.3-1 rpm, I was able to switch to french,
now I want to go back to us (english) but my menus are still in french. 

In my kdeglobals file I have

[Locale]
Country=us
Language=en_US

the time format is for instance in the us format but the main KDE is still in
french.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Went to configuration center
2. Changed the country to us and the language to us
3. logout from KDE then login
    

Actual Results:  My menus are still in french

Expected Results:  Menus in english

Additional info:
Comment 1 Need Real Name 2003-02-26 00:11:02 EST
(no debugging symbols found)...[New Thread 8192 (LWP 10060)]
0x420ae169 in wait4 () from /lib/i686/libc.so.6
#0  0x420ae169 in wait4 () from /lib/i686/libc.so.6
#1  0x4212a2d0 in __DTOR_END__ () from /lib/i686/libc.so.6
#2  0x40e22c63 in waitpid () from /lib/i686/libpthread.so.0
#3  0x406331e5 in KCrash::defaultCrashHandler(int) ()
   from /usr/lib/libkdecore.so.4
#4  <signal handler called>
#5  0x4097b2e2 in QComboBox::currentText() const ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#6  0x41b14428 in LayoutConfig::save() () from /usr/lib/kde3/kcm_keyboard.so
#7  0x40029abb in KCDialog::slotApply() () from /usr/lib/kcmshell.so
#8  0x4045be5a in KDialogBase::qt_invoke(int, QUObject*) ()
   from /usr/lib/libkdeui.so.4
#9  0x40029413 in KCDialog::qt_invoke(int, QUObject*) ()
   from /usr/lib/kcmshell.so
#10 0x408f5d10 in QObject::activate_signal(QConnectionList*, QUObject*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#11 0x408f5c57 in QObject::activate_signal(int) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#12 0x40bc2b4e in QButton::clicked() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#13 0x40977c76 in QButton::mouseReleaseEvent(QMouseEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#14 0x4092a36c in QWidget::event(QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#15 0x408a1c49 in QApplication::internalNotify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#16 0x408a1363 in QApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#17 0x405c79c6 in KApplication::notify(QObject*, QEvent*) ()
   from /usr/lib/libkdecore.so.4
#18 0x40845b46 in QETWidget::translateMouseEvent(_XEvent const*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#19 0x408429b6 in QApplication::x11ProcessEvent(_XEvent*) ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#20 0x4084252f in QApplication::processNextEvent(bool) ()
I did get this error message while trying to change
keyboard primary layout from en to lt,
I was doing that because no  us/lt button was there  

   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#21 0x408a3280 in QApplication::enter_loop() ()
   from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#22 0x40a508c1 in QDialog::exec() () from /usr/lib/qt3-gcc3.2/lib/libqt-mt.so.3
#23 0x40023201 in main () from /usr/lib/kcmshell.so
#24 0x0804cb9f in strcpy ()
#25 0x0804d8bb in strcpy ()
#26 0x0804dd7c in strcpy ()
#27 0x0804eb40 in strcpy ()
#28 0x420158d4 in __libc_start_main () from /lib/i686/libc.so.6
Comment 2 Need Real Name 2003-02-26 00:18:01 EST
The KDE3.0 error message did appear while changing primary keyboard layout from
us to lt,
I did that because there was no us/lt button,
I am writing here because I suppose that the problems can be related 
Comment 3 Need Real Name 2003-02-26 00:52:58 EST
That error message apeared while trying to change primary keyboard layout from
us to lt.
I was doing that because there was no us/lt button.
Comment 4 Need Real Name 2003-02-26 00:54:39 EST
That error message apeared while trying to change primary keyboard layout from
us to lt.
I was doing that because there was no us/lt button.
Comment 5 Petr Rockai 2006-07-17 14:24:15 EDT
This bug is reported against old release of Red Hat Linux or Fedora Core 
that is no longer supported. Chances are that it has been already fixed in 
newer Fedora Core release. If you still experience the problem with 
current release of Fedora Core, please update the Version field (you may 
need to switch Product to Fedora Core first) in the bug report and put it 
back to NEW state.
Comment 6 Bill Nottingham 2006-10-18 14:25:48 EDT
Red Hat Linux is no longer supported by Red Hat, Inc. If you are still
running Red Hat Linux, you are strongly advised to upgrade to a
current Fedora Core release or Red Hat Enterprise Linux or comparable.
Some information on which option may be right for you is available at
http://www.redhat.com/rhel/migrate/redhatlinux/.

Red Hat apologizes that these issues have not been resolved yet. We do
want to make sure that no important bugs slip through the cracks.
If this issue is still present in a current Fedora Core release, please
open a new bug with the relevant information.

Closing as CANTFIX.

Note You need to log in before you can comment on or make changes to this bug.