Bug 828704 - [abrt] evolution-data-server-3.4.1-2.fc17: g_str_hash: Process /usr/libexec/evolution-addressbook-factory was killed by signal 11 (SIGSEGV)
[abrt] evolution-data-server-3.4.1-2.fc17: g_str_hash: Process /usr/libexec/e...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
abrt_hash:9884fd83de859fac4796de15b46...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 04:35 EDT by Matthew Saltzman
Modified: 2012-08-11 05:41 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 03:12:23 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: backtrace (47.07 KB, text/plain)
2012-06-05 04:36 EDT, Matthew Saltzman
no flags Details
File: maps (89.77 KB, text/plain)
2012-06-05 04:36 EDT, Matthew Saltzman
no flags Details
File: dso_list (19.61 KB, text/plain)
2012-06-05 04:36 EDT, Matthew Saltzman
no flags Details
File: build_ids (8.17 KB, text/plain)
2012-06-05 04:36 EDT, Matthew Saltzman
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 677531 None None None 2012-06-06 03:12:23 EDT

  None (edit)
Description Matthew Saltzman 2012-06-05 04:35:58 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/libexec/evolution-addressbook-factory
crash_function: g_str_hash
executable:     /usr/libexec/evolution-addressbook-factory
kernel:         3.3.7-1.fc17.x86_64
pid:            1623
pwd:            /
time:           Mon 04 Jun 2012 04:45:53 PM EDT
uid:            1000
username:       mjs
var_log_messages: Jun  4 16:45:54 serenity abrt[13507]: Saved core dump of pid 1623 (/usr/libexec/evolution-addressbook-factory) to /var/spool/abrt/ccpp-2012-06-04-16:45:53-1623 (138055680 bytes)

backtrace:      Text file, 48201 bytes
build_ids:      Text file, 8364 bytes
dso_list:       Text file, 20083 bytes
maps:           Text file, 91926 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/mjs/2

comment:
:Appears to have happened during background operation.  My contacts page shows a frozen progress disk with the message "Syncing contacts...".  The contact list in question is on MS Exchange via evolution-ews.
:Can't exit evolution after failure--have to force-shutdown.

core_backtrace:
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x38610 g_str_hash libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x37750 - libglib-2.0.so.0 -
:b3f120116115fbf8addee6b054e384a45e35587c 0x22fb0 - libedata-book-1.2.so.13 -
:b3f120116115fbf8addee6b054e384a45e35587c 0x2328d e_data_book_view_notify_update libedata-book-1.2.so.13 -
:b3f120116115fbf8addee6b054e384a45e35587c 0x1c599 - libedata-book-1.2.so.13 -
:b3f120116115fbf8addee6b054e384a45e35587c 0x1d18d e_book_backend_foreach_view libedata-book-1.2.so.13 -
:389691082fb900b5fcbfde7f4b73e9b2ff8038ab 0xd6cf - libebookbackendews.so -
:389691082fb900b5fcbfde7f4b73e9b2ff8038ab 0xc838 ews_oab_decoder_decode libebookbackendews.so -
:389691082fb900b5fcbfde7f4b73e9b2ff8038ab 0xf023 - libebookbackendews.so -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x6a345 - libglib-2.0.so.0 -
:73777e822e00ca152ffca281ab0ace0cb498ec48 0x7d14 start_thread libpthread.so.0 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0xf199d clone libc.so.6 -

environ:
:SHELL=/bin/bash
:DBUS_STARTER_ADDRESS=unix:abstract=/tmp/dbus-TvXvsYnKRK,guid=766621d7e78a30af894c887900000075
:XDG_RUNTIME_DIR=/run/user/mjs
:DISPLAY=:0
:DESKTOP_SESSION=gnome
:SSH_AUTH_SOCK=/run/user/mjs/keyring-4bZJt8/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1220,unix/unix:/tmp/.ICE-unix/1220
:WINDOWPATH=1
:PATH=/usr/local/bin:/usr/bin:/bin
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:XDG_VTNR=1
:USERNAME=mjs
:GDMSESSION=gnome
:XDG_SESSION_ID=2
:GPG_AGENT_INFO=/run/user/mjs/keyring-4bZJt8/gpg:0:1
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-TvXvsYnKRK,guid=766621d7e78a30af894c887900000075
:XDG_SEAT=seat0
:XAUTHORITY=/var/run/gdm/auth-for-mjs-b40vMo/database
:USER=mjs
:DBUS_STARTER_BUS_TYPE=session
:GNOME_KEYRING_PID=1216
:SHLVL=1
:PWD=/home/mjs
:GNOME_KEYRING_CONTROL=/run/user/mjs/keyring-4bZJt8
:LANG=en_US.UTF-8
:_=/usr/bin/dbus-launch
:LOGNAME=mjs
:HOME=/home/mjs

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 63664                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       63664                63664                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100002
:1:/dev/null
:pos:	0
:flags:	0100002
:2:/dev/null
:pos:	0
:flags:	0100002
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:/dev/null
:pos:	0
:flags:	0100002
:5:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:6:socket:[24124]
:pos:	0
:flags:	04002
:7:socket:[24125]
:pos:	0
:flags:	02004002
:8:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:10:/home/mjs/.local/share/evolution/addressbook/system/addressbook.db
:pos:	0
:flags:	02100002
:11:/home/mjs/.local/share/evolution/addressbook/system/log.0000000001
:pos:	28
:flags:	02100002
:12:/home/mjs/.local/share/evolution/addressbook/system/contacts.db
:pos:	40
:flags:	02100002
:13:/home/mjs/.cache/evolution/addressbook/ews___mjs@clemson.edu_mjs@clemson.edu_;gal=1/contacts.db
:pos:	730112
:flags:	02100002
:14:socket:[14661186]
:pos:	0
:flags:	02004002
:15:socket:[14744953]
:pos:	0
:flags:	02004002
:16:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:17:/dev/urandom
:pos:	0
:flags:	02100000
:18:socket:[56219]
:pos:	0
:flags:	02000002
:19:socket:[13591668]
:pos:	0
:flags:	02004002
:20:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:21:/home/mjs/.cache/evolution/addressbook/ews___mjs@clemson.edu_mjs@clemson.edu_;folderid=AAMkAGRkZDM1OWJkLWQwYzQtNGIxMy05MDMzLTg2ZmIxNWI4ZmEwNAAuAAAAAAAJW3V3mKJ+RJMVK2hr1NukAQC8B111o7BIQZBKNvUt1dfnAAAACfg7AAA=/contacts.db
:pos:	40
:flags:	02100002
:22:/home/mjs/.cache/evolution/addressbook/ews___mjs@clemson.edu_mjs@clemson.edu_;folderid=AAMkAGRkZDM1OWJkLWQwYzQtNGIxMy05MDMzLTg2ZmIxNWI4ZmEwNAAuAAAAAAAJW3V3mKJ+RJMVK2hr1NukAQBV2_yorPbqRYHjAwvi_uskAAAAAZLwAAA=/contacts.db
:pos:	254976
:flags:	02100002
:23:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:24:socket:[13592672]
:pos:	0
:flags:	02004002
:25:socket:[14748716]
:pos:	0
:flags:	02004002
:26:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:27:socket:[14743366]
:pos:	0
:flags:	02004002
:28:socket:[14749701]
:pos:	0
:flags:	02004002
:29:/home/mjs/.cache/evolution/addressbook/ews___mjs@clemson.edu_mjs@clemson.edu_;gal=1/\Global Address List-1200.oab
:pos:	2534797
:flags:	0100000
Comment 1 Matthew Saltzman 2012-06-05 04:36:05 EDT
Created attachment 589433 [details]
File: backtrace
Comment 2 Matthew Saltzman 2012-06-05 04:36:06 EDT
Created attachment 589434 [details]
File: maps
Comment 3 Matthew Saltzman 2012-06-05 04:36:09 EDT
Created attachment 589435 [details]
File: dso_list
Comment 4 Matthew Saltzman 2012-06-05 04:36:11 EDT
Created attachment 589436 [details]
File: build_ids
Comment 5 Milan Crha 2012-06-06 03:12:23 EDT
Thanks for a bug report. I moved this upstream as [1]. Please see [1] for any further updates. If possible, please CC yourself there, in case upstream developers will have additional questions.

I also wrote in the upstream bugzilla what I see from the backtrace. I'm afraid there is no workaround for this crash currently, except of removing GAL from GConf keys, thus it'll not be used at all.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=677531
Comment 6 Matthew Saltzman 2012-06-06 09:45:46 EDT
Thanks.  Looks like there's already a workaround patch upstream.  If you could port it down, that would be great.
Comment 7 Milan Crha 2012-06-11 03:41:15 EDT
3.4.3 will be released the next Monday, then it'll be available in updates-testing with other fixes. I hope you are fine with this.
Comment 8 Tim Zorn 2012-08-11 05:41:31 EDT
I'm getting this error on Fedora 16

Note You need to log in before you can comment on or make changes to this bug.