Bug 828737 - many conflicts for yum upgrade after DVD install of fc17 via upgrade option
many conflicts for yum upgrade after DVD install of fc17 via upgrade option
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Packaging Toolset Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 05:44 EDT by Craig
Modified: 2014-01-21 18:22 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-21 15:40:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
has yum error output and a list of packages installed on my system before the command (362.50 KB, application/octet-stream)
2012-06-05 05:44 EDT, Craig
no flags Details

  None (edit)
Description Craig 2012-06-05 05:44:10 EDT
Created attachment 589454 [details]
has yum error output and a list of packages installed on my system before the command

Description of problem:

After upgrading to fedora 17 (x86_64) from DVD via the DVD's "upgrade existing system" option, reboot and try to do "yum upgrade" [or update--doesn't matter].  yum detects a massive number of missing requisites/conflicts because it is getting confused between the .x86_64 arch and the .i686 arch, or between fc17 and prior ones.

Version-Release number of selected component (if applicable):


How reproducible:

Using Fedora install DVD's, install earlier version (e.g. fc15).  This is x86_64, but additionally install some i686 versions of packages (e.g. install a bunch of i686 devel packages or libraries that already have their x86_64 versions installed).  Install fc16 via the DVD "upgrade" option.  Then upgrade (via DVD) to fc17.  Reboot and run "yum upgrade"


Steps to Reproduce:
1.Install fedora version using DVD "upgrade existing system" option
2.reboot
3.yum upgrade

Repeat this for fc15-fc17
  
Actual results:

yum will equate package.fc17.x86_64 and package.fc16.i686 and complain about a duplicate

Expected results:

clean upgrade, which happened just fine when upgrading from fc15 to fc16


Additional info:

On one system, the workaround was to list the installed packages and then do a "yum remove" followed by a "yum install" for any package that was more than one rev back (e.g. fc15's)
Comment 1 James Antill 2013-05-21 15:40:36 EDT
 I assume there were a lot of output with "yum check". There's not much yum can do in this case, apart from help you to fix it.

Note You need to log in before you can comment on or make changes to this bug.