Bug 828762 - [openshift_origin_livecd]Jboss app will fail to git push via jenkins server if not change medium to small gear manually
[openshift_origin_livecd]Jboss app will fail to git push via jenkins server i...
Status: CLOSED CURRENTRELEASE
Product: OpenShift Origin
Classification: Red Hat
Component: Containers (Show other bugs)
2.x
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Rob Millner
libra bugs
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 06:27 EDT by yquan
Modified: 2015-05-14 18:55 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-25 14:27:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description yquan 2012-06-05 06:27:43 EDT
Description of problem:
Jboss app will fail when git push with jenkins server.
It can git push successfully after change the build size of jenkins' configure to small.
The default build size of jboss is medium,but the livecd is not have gear size concept.
So I think the default Jboss build size should small on livecd.
And the livecd user can git push the jboss app via jenkins server without any configure .


Version-Release number of selected component (if applicable):
Livecd on Jun 04th.

How reproducible:
always.

Steps to Reproduce:
1.create a jboss app and enable the jenkins
2.make some change and git push.
3.
  
Actual results:
It will fail to git push jboss app because of the medium build size.

Expected results:
It should git push without any configure.

Additional info:
Comment 1 Rob Millner 2012-06-14 14:58:34 EDT
Should/can the jenkins builder for jboss just change gear size to small?
Comment 2 Krishna Raman 2012-06-14 15:55:01 EDT
Mrunal added a config field to ignore gear sizes which we I was planning to use on origin.
Comment 3 Rob Millner 2012-06-14 16:38:49 EDT
Changing default builder size to small.  Crankcase commit 8d605d0, pull request #128.
Comment 4 Rob Millner 2012-06-14 16:39:41 EDT
Tested against kitchensink-example, kitchensink-html5-mobile-example and jbossas-mongoDB-quickstart.
Comment 5 Meng Bo 2012-06-15 05:13:26 EDT
Checked on devenv_1846, the default builder size of jbossas app is small now.

Note You need to log in before you can comment on or make changes to this bug.