Bug 828795 - Channel deletion results in traceback with integrity constraint RHNSAT.RHN_EQUEUE_CID_FK or RHNSAT.RHN_ENQUEUE_CID_FK violation
Channel deletion results in traceback with integrity constraint RHNSAT.RHN_EQ...
Status: CLOSED ERRATA
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Server (Show other bugs)
541
All Linux
high Severity medium
: ---
: ---
Assigned To: Jan Pazdziora
Martin Minar
:
Depends On:
Blocks: sat541-triage
  Show dependency treegraph
 
Reported: 2012-06-05 07:47 EDT by dipu
Modified: 2016-07-03 20:57 EDT (History)
8 users (show)

See Also:
Fixed In Version: satellite-schema-5.4.0.20-1-sat
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-22 07:23:56 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Comment 8 Xixi 2012-09-12 00:30:24 EDT
Public bug summary:

Description of problem:
Channel deletion (such as via spacewalk-remove-channel) fails with ORA-02292 constraint violation error for either RHNSAT.RHN_EQUEUE_CID_FK or RHNSAT.RHN_ENQUEUE_CID_FK.

Sample error:
---------------------
[root@rhnsat ~]# spacewalk-remove-channel -c rhel-ia64-ws-3-extras

ERROR: unhandled exception occurred: ((2292, 'ORA-02292: integrity constraint (RHNSAT.RHN_EQUEUE_CID_FK) violated - child record found\n', 'delete from rhnChannel where id = :channel_id')).
----------------------

Version-Release number of selected component (if applicable):
RHN Satellite v5.4

How reproducible:
Always for the problematic channel(s).

Steps to Reproduce:
(see above)

Actual results:
channel deletion fails with ORA-02292 error

Expected results:
channel deletion succeeds

Additional info:
Comment 11 errata-xmlrpc 2012-10-22 07:23:56 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1395.html

Note You need to log in before you can comment on or make changes to this bug.