Bug 828801 - [RHEVM-Installer] [Notifierd service] - Can't start notification service: "can't run without missing JAR file"
[RHEVM-Installer] [Notifierd service] - Can't start notification service: "ca...
Status: CLOSED DUPLICATE of bug 813765
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-setup (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Juan Hernández
yeylon@redhat.com
infra
: Regression, TestBlocker
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 07:58 EDT by Ortal
Modified: 2016-04-18 02:52 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-21 07:51:17 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ortal 2012-06-05 07:58:25 EDT
Description of problem:

[RHEVM-Installer] [Notifierd service] - Can't start notification service: "can't run without missing JAR file"

Version-Release number of selected component (if applicable):
RHEVM 3.1 Private patch rhevm-3.1.0_0001-0.scratch.el6ev.noarch

How reproducible:
Always

Steps to Reproduce:
1. Attempt to run engine-notifierd service after configure all definitions under /etc/ovirt-engine/notifier/notifier.conf 
  
Actual results:

Getting an Error:

[root@ortal-rhevm1 ~]# /etc/init.d/engine-notifierd start
Starting engine-notifier: at Tue Jun  5 14:44:46 IDT 2012Error: can't run without missing JAR file: /usr/share/java/engine-tools-common.jar
                                                           [FAILED]

Expected results:

After speaking with Juan, it should work with no errors.
Comment 1 Juan Hernández 2012-06-05 08:57:29 EDT
The problem here is that the changes I did for Fedora 17 changed the location of some jar files, but I didn't fix properly the classpath used by the notifier.
Comment 2 Juan Hernández 2012-06-06 14:56:12 EDT
The proposed solution for this problem is here:

http://gerrit.ovirt.org/#/c/5111
Comment 3 Juan Hernández 2012-06-21 07:19:01 EDT
Bug 813765 is closely related to this, if not a duplicate.
Comment 5 Yaniv Kaul 2012-06-21 07:51:17 EDT

*** This bug has been marked as a duplicate of bug 813765 ***

Note You need to log in before you can comment on or make changes to this bug.