Bug 828828 - Seam 2.3 needs to support JBDS
Seam 2.3 needs to support JBDS
Status: CLOSED DUPLICATE of bug 825037
Product: JBoss Enterprise WFK Platform 2
Classification: JBoss
Component: Seam (Show other bugs)
2.0.0.ER7
Unspecified Unspecified
urgent Severity urgent
: ---
: 2.0.0.ER8
Assigned To: Marek Novotny
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 08:43 EDT by Rodney Russ
Modified: 2012-08-23 09:21 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 09:05:45 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Rodney Russ 2012-06-05 08:43:24 EDT
Description of problem:

The Seam 2.3 distribution that is included with WFK must be usable from JBDS
Comment 1 Rodney Russ 2012-06-05 09:05:45 EDT

*** This bug has been marked as a duplicate of bug 825037 ***
Comment 2 JBoss JIRA Server 2012-06-07 02:37:11 EDT
Daniel Hinojosa <dhinojosa@evolutionnext.com> made a comment on jira JBSEAM-4960

[~akazakov] I have migrated the .project, .classpath, and .settings files to what I believe to be the latest Eclipse/JBT standards.  What I have now, is this message.

{noformat}
org.jboss.tools.common.validation.JBTValidationException
	at org.jboss.tools.common.validation.ValidatorManager.validateInJob(ValidatorManager.java:101)
	at org.eclipse.wst.validation.internal.operations.ValidatorJob.run(ValidatorJob.java:78)
	at org.eclipse.core.internal.jobs.Worker.run(Worker.java:54)
Caused by: java.lang.NullPointerException
	at org.jboss.tools.jsf.web.validation.FacesConfigValidator.validateAll(FacesConfigValidator.java:314)
	at org.jboss.tools.common.validation.ValidatorManager.validateAll(ValidatorManager.java:132)
	at org.jboss.tools.common.validation.ValidatorManager.validateInJob(ValidatorManager.java:84)
	... 2 more
{noformat}

See attached files of all the settings I have currently.  I know I have something missing, but I am not sure what.  BTW, the test project is called 'grapesofstash'.
Comment 3 JBoss JIRA Server 2012-06-07 02:39:44 EDT
Daniel Hinojosa <dhinojosa@evolutionnext.com> made a comment on jira JBSEAM-4960

All the files currently migrated over to JBT for Seam 2.3
Comment 4 JBoss JIRA Server 2012-06-07 07:32:08 EDT
Max Rydahl Andersen <max.andersen@redhat.com> made a comment on jira JBSEAM-4960

Daniel - could you open a JBIDE specific bug on how to reproduce the NPE you get in facesconfigvalidator ?
Comment 5 JBoss JIRA Server 2012-06-07 11:36:33 EDT
Daniel Hinojosa <dhinojosa@evolutionnext.com> made a comment on jira JBSEAM-4960

[~maxandersen] Done Max, https://issues.jboss.org/browse/JBIDE-12129.
Comment 6 JBoss JIRA Server 2012-06-07 14:56:23 EDT
Alexey Kazakov <akazakov@exadel.com> made a comment on jira JBSEAM-4960

Target namespace in components.xml in CR1 was changed from http://jboss.com/products/seam/components to http://jboss.org/schema/seam/components
It caused some critical promlems for JBoss Tools.
See JBIDE-12132 for details
Comment 7 JBoss JIRA Server 2012-06-07 15:09:31 EDT
Alexey Kazakov <akazakov@exadel.com> made a comment on jira JBIDE-11490

I've just tested Seam 2.3.CR1 WAR project generated by JBT
1. See https://issues.jboss.org/browse/JBIDE-12132
2. In runtime it seems to work. But..
3. If I genearate new Action, Form, etc. (we use seam-gen templates for that) then the app fails.
   EL cannot be resolved to the new components
   I don't see any changes in these templates from Seam 2.2. So it seems that something was changed in Seam or JSF and these templates are not quite correct.
   Anyway it's a problem of seam-gen templates. Not JBT.
Comment 8 JBoss JIRA Server 2012-06-07 15:25:08 EDT
Alexey Kazakov <akazakov@exadel.com> made a comment on jira JBIDE-11490

I've just tested Seam 2.3.CR1 WAR and EAR projects generated by JBT
1. See https://issues.jboss.org/browse/JBIDE-12132
2. In runtime it seems to work. But..
3. If I genearate new Action, Form, etc. (we use seam-gen templates for that) then the app fails.
   EL cannot be resolved to the new components
   I don't see any changes in these templates from Seam 2.2. So it seems that something was changed in Seam or JSF and these templates are not quite correct.
   Anyway it's a problem of seam-gen templates. Not JBT.
{code}
Caused by: javax.naming.NameNotFoundException: seamear-ear/NewActionBean/local -- service jboss.naming.context.java.seamear-ear.NewActionBean.local
	at org.jboss.as.naming.ServiceBasedNamingStore.lookup(ServiceBasedNamingStore.java:97)
	at org.jboss.as.naming.NamingContext.lookup(NamingContext.java:178)
	at org.jboss.as.naming.InitialContext.lookup(InitialContext.java:113)
	at org.jboss.as.naming.NamingContext.lookup(NamingContext.java:214)
	at javax.naming.InitialContext.lookup(InitialContext.java:392) [rt.jar:1.6.0_31]
	at org.jboss.seam.Component.instantiateSessionBean(Component.java:1403) [jboss-seam.jar:2.3.0.CR1-SNAPSHOT]
	at org.jboss.seam.Component.instantiate(Component.java:1367) [jboss-seam.jar:2.3.0.CR1-SNAPSHOT]
	at org.jboss.seam.Component.newInstance(Component.java:2148) [jboss-seam.jar:2.3.0.CR1-SNAPSHOT]
{code}
Comment 9 JBoss JIRA Server 2012-06-07 15:26:25 EDT
Alexey Kazakov <akazakov@exadel.com> made a comment on jira JBIDE-11490

I've just tested Seam 2.3.CR1 WAR and EAR projects generated by JBT
# See https://issues.jboss.org/browse/JBIDE-12132
# In runtime it seems to work. But..
# If I genearate new Action, Form, etc. (we use seam-gen templates for that) then the app fails.
   EL cannot be resolved to the new components
   I don't see any changes in these templates from Seam 2.2. So it seems that something was changed in Seam or JSF and these templates are not quite correct.
   Anyway it's a problem of seam-gen templates. Not JBT.
{code}
Caused by: javax.naming.NameNotFoundException: seamear-ear/NewActionBean/local -- service jboss.naming.context.java.seamear-ear.NewActionBean.local
	at org.jboss.as.naming.ServiceBasedNamingStore.lookup(ServiceBasedNamingStore.java:97)
	at org.jboss.as.naming.NamingContext.lookup(NamingContext.java:178)
	at org.jboss.as.naming.InitialContext.lookup(InitialContext.java:113)
	at org.jboss.as.naming.NamingContext.lookup(NamingContext.java:214)
	at javax.naming.InitialContext.lookup(InitialContext.java:392) [rt.jar:1.6.0_31]
	at org.jboss.seam.Component.instantiateSessionBean(Component.java:1403) [jboss-seam.jar:2.3.0.CR1-SNAPSHOT]
	at org.jboss.seam.Component.instantiate(Component.java:1367) [jboss-seam.jar:2.3.0.CR1-SNAPSHOT]
	at org.jboss.seam.Component.newInstance(Component.java:2148) [jboss-seam.jar:2.3.0.CR1-SNAPSHOT]
{code}
Comment 10 JBoss JIRA Server 2012-06-07 20:00:52 EDT
Alexey Kazakov <akazakov@exadel.com> made a comment on jira JBSEAM-4960

.settings/org.jboss.tools.seam.core.prefs has some errors:

*seam.project.web.root.folder=/myproject/WebContent*
should be
*seam.project.web.root.folder=/myproject/view*
Comment 11 JBoss JIRA Server 2012-06-07 20:03:11 EDT
Alexey Kazakov <akazakov@exadel.com> made a comment on jira JBSEAM-4960

.classpath still has two missing libs:
<classpathentry kind="lib" path="lib/jboss-as-embedded-7.1.1.Final.jar"/>
<classpathentry kind="lib" path="lib/testng-jdk15.jar"/>
Comment 12 JBoss JIRA Server 2012-06-07 20:07:07 EDT
Alexey Kazakov <akazakov@exadel.com> made a comment on jira JBSEAM-4960

.settings/org.eclipse.wst.common.component points to the missing folder WebContent:
<wb-resource deploy-path="/" source-path="/WebContent" tag="defaultRootSource"/>
Comment 13 JBoss JIRA Server 2012-06-07 20:07:51 EDT
Alexey Kazakov <akazakov@exadel.com> made a comment on jira JBSEAM-4960

.settings/org.eclipse.wst.common.component points to the missing folder WebContent:
<wb-resource deploy-path="/" source-path="/WebContent" tag="defaultRootSource"/>

I guess it should be something like:

<wb-resource deploy-path="/" source-path="/resources" tag="defaultRootSource"/>
<wb-resource deploy-path="/" source-path="/view" tag="defaultRootSource"/>
Comment 14 JBoss JIRA Server 2012-06-07 20:09:37 EDT
Alexey Kazakov <akazakov@exadel.com> made a comment on jira JBSEAM-4960

.settings/org.eclipse.wst.common.component points to the missing folder WebContent:
<wb-resource deploy-path="/" source-path="/WebContent" tag="defaultRootSource"/>

I guess it should be something like:

<wb-resource deploy-path="/" source-path="/resources" tag="defaultRootSource"/>
<wb-resource deploy-path="/" source-path="/view"/>
Comment 15 JBoss JIRA Server 2012-06-07 20:10:27 EDT
Alexey Kazakov <akazakov@exadel.com> made a comment on jira JBSEAM-4960

.settings/org.eclipse.wst.common.component points to the missing folder WebContent:
{code}
...
<wb-resource deploy-path="/" source-path="/WebContent" tag="defaultRootSource"/>
{code}

I guess it should be something like:

{code}
...
<wb-resource deploy-path="/" source-path="/resources" tag="defaultRootSource"/>
<wb-resource deploy-path="/" source-path="/view"/>
...
{code}
Comment 16 JBoss JIRA Server 2012-06-08 02:21:54 EDT
Marek Novotny <mnovotny@redhat.com> made a comment on jira JBSEAM-4960

{quote}
Alexey Kazakov added a comment - 08/Jun/12 2:03 AM

.classpath still has two missing libs:
<classpathentry kind="lib" path="lib/jboss-as-embedded-7.1.1.Final.jar"/>
<classpathentry kind="lib" path="lib/testng-jdk15.jar"/>
{quote}

1. there should be *lib/test/jboss-as-embedded-7.1.1.Final.jar* instead of -lib/jboss-as-embedded-7.1.1.Final.jar-
2. there should be *testng.jar* instead of -testng-jdk15.jar-
Comment 17 JBoss JIRA Server 2012-06-11 15:48:17 EDT
Daniel Hinojosa <dhinojosa@evolutionnext.com> updated the status of jira JBSEAM-4960 to Resolved
Comment 18 JBoss JIRA Server 2012-06-11 15:48:17 EDT
Daniel Hinojosa <dhinojosa@evolutionnext.com> made a comment on jira JBSEAM-4960

Sorry for the delay, seems the eclipse I had was corrupted and were showing errors that shouldn't have been displayed.
Comment 19 JBoss JIRA Server 2012-06-12 05:02:59 EDT
Martin Malina <mmalina@redhat.com> made a comment on jira JBIDE-11490

Today I started testing with Seam 2.3 Beta2 from WFK 2.0 ER8 and the issues Marek lists above are present (of course). Otherwise the generated apps seem to work, I even tried created an action. But when you deploy the app, this is in the server log:
{code}

10:56:26,539 WARN  [org.jboss.modules] (MSC service thread 1-4) Failed to define class org.drools.WorkingMemoryEntryPoint in Module "deployment.seamproj.war:main" from Service Module Loader: java.lang.LinkageError: Failed to link org/drools/WorkingMemoryEntryPoint (Module "deployment.seamproj.war:main" from Service Module Loader)
	at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:396)
	at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:243)
	at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:73)
	at org.jboss.modules.Module.loadModuleClass(Module.java:527)
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:182)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
	at java.lang.ClassLoader.defineClass1(Native Method) [classes.jar:1.6.0_31]
	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631) [classes.jar:1.6.0_31]
	at java.lang.ClassLoader.defineClass(ClassLoader.java:615) [classes.jar:1.6.0_31]
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) [classes.jar:1.6.0_31]
	at org.jboss.modules.ModuleClassLoader.doDefineOrLoadClass(ModuleClassLoader.java:327)
	at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:391)
	at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:243)
	at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:73)
	at org.jboss.modules.Module.loadModuleClass(Module.java:527)
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:182)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
	at org.jboss.seam.init.DependencyManager.checkClassDependencies(DependencyManager.java:138) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.checkAllDependencies(DependencyManager.java:98) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.tryToInstall(DependencyManager.java:93) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.tryToInstall(DependencyManager.java:69) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.computeInstallSet(DependencyManager.java:49) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.installedSet(DependencyManager.java:30) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.Initialization.installComponents(Initialization.java:1111) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.Initialization.init(Initialization.java:737) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.servlet.SeamListener.contextInitialized(SeamListener.java:36) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.apache.catalina.core.StandardContext.contextListenerStart(StandardContext.java:3392) [jbossweb-7.0.16.Final-redhat-1.jar:]
	at org.apache.catalina.core.StandardContext.start(StandardContext.java:3850) [jbossweb-7.0.16.Final-redhat-1.jar:]
	at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:90) [jboss-as-web-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [classes.jar:1.6.0_31]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [classes.jar:1.6.0_31]
	at java.lang.Thread.run(Thread.java:680) [classes.jar:1.6.0_31]
Caused by: java.lang.NoClassDefFoundError: org/drools/runtime/rule/WorkingMemoryEntryPoint
	at java.lang.ClassLoader.defineClass1(Native Method) [classes.jar:1.6.0_31]
	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631) [classes.jar:1.6.0_31]
	at java.lang.ClassLoader.defineClass(ClassLoader.java:615) [classes.jar:1.6.0_31]
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) [classes.jar:1.6.0_31]
	at org.jboss.modules.ModuleClassLoader.doDefineOrLoadClass(ModuleClassLoader.java:327)
	at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:391)
	... 41 more
Caused by: java.lang.ClassNotFoundException: org.drools.runtime.rule.WorkingMemoryEntryPoint from [Module "deployment.seamproj.war:main" from Service Module Loader]
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
	... 47 more

10:56:26,543 WARN  [org.jboss.modules] (MSC service thread 1-4) Failed to define class org.drools.WorkingMemory in Module "deployment.seamproj.war:main" from Service Module Loader: java.lang.LinkageError: Failed to link org/drools/WorkingMemory (Module "deployment.seamproj.war:main" from Service Module Loader)
	at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:396)
	at org.jboss.modules.ModuleClassLoader.loadClassLocal(ModuleClassLoader.java:243)
	at org.jboss.modules.ModuleClassLoader$1.loadClassLocal(ModuleClassLoader.java:73)
	at org.jboss.modules.Module.loadModuleClass(Module.java:527)
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:182)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
	at org.jboss.seam.init.DependencyManager.checkClassDependencies(DependencyManager.java:138) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.checkAllDependencies(DependencyManager.java:98) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.tryToInstall(DependencyManager.java:93) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.tryToInstall(DependencyManager.java:69) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.computeInstallSet(DependencyManager.java:49) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.DependencyManager.installedSet(DependencyManager.java:30) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.Initialization.installComponents(Initialization.java:1111) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.init.Initialization.init(Initialization.java:737) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.jboss.seam.servlet.SeamListener.contextInitialized(SeamListener.java:36) [jboss-seam.jar:2.3.0.Beta2-redhat-1]
	at org.apache.catalina.core.StandardContext.contextListenerStart(StandardContext.java:3392) [jbossweb-7.0.16.Final-redhat-1.jar:]
	at org.apache.catalina.core.StandardContext.start(StandardContext.java:3850) [jbossweb-7.0.16.Final-redhat-1.jar:]
	at org.jboss.as.web.deployment.WebDeploymentService.start(WebDeploymentService.java:90) [jboss-as-web-7.1.2.Final-redhat-1.jar:7.1.2.Final-redhat-1]
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.startService(ServiceControllerImpl.java:1811)
	at org.jboss.msc.service.ServiceControllerImpl$StartTask.run(ServiceControllerImpl.java:1746)
	at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886) [classes.jar:1.6.0_31]
	at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908) [classes.jar:1.6.0_31]
	at java.lang.Thread.run(Thread.java:680) [classes.jar:1.6.0_31]
Caused by: java.lang.NoClassDefFoundError: org/drools/WorkingMemoryEntryPoint
	at java.lang.ClassLoader.defineClass1(Native Method) [classes.jar:1.6.0_31]
	at java.lang.ClassLoader.defineClassCond(ClassLoader.java:631) [classes.jar:1.6.0_31]
	at java.lang.ClassLoader.defineClass(ClassLoader.java:615) [classes.jar:1.6.0_31]
	at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:141) [classes.jar:1.6.0_31]
	at org.jboss.modules.ModuleClassLoader.doDefineOrLoadClass(ModuleClassLoader.java:327)
	at org.jboss.modules.ModuleClassLoader.defineClass(ModuleClassLoader.java:391)
	... 25 more
Caused by: java.lang.ClassNotFoundException: org.drools.WorkingMemoryEntryPoint from [Module "deployment.seamproj.war:main" from Service Module Loader]
	at org.jboss.modules.ModuleClassLoader.findClass(ModuleClassLoader.java:190)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassUnchecked(ConcurrentClassLoader.java:468)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:456)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClassChecked(ConcurrentClassLoader.java:423)
	at org.jboss.modules.ConcurrentClassLoader.performLoadClass(ConcurrentClassLoader.java:398)
	at org.jboss.modules.ConcurrentClassLoader.loadClass(ConcurrentClassLoader.java:120)
	... 31 more
{code}
Comment 20 Marek Novotny 2012-06-12 07:16:06 EDT
Check if there is knowledge-api.jar in EAR (i guess it is ear). That issue i already fixed and the fix should be in ER8. Can you validate your Seam runtime?

Please use https://bugzilla.redhat.com/show_bug.cgi?id=825037 instead of this issue
Comment 21 JBoss JIRA Server 2012-06-12 07:27:19 EDT
Martin Malina <mmalina@redhat.com> made a comment on jira JBIDE-11490

Marek, no, it's not ear, it's a war project and there is no knowledge-api.jar. My Seam runtime is from WFK ER8 for sure.
Comment 22 JBoss JIRA Server 2012-06-12 07:50:48 EDT
Marek Novotny <mnovotny@redhat.com> made a comment on jira JBIDE-11490

then it is clear why it happens, war list jars is not fixed http://anonsvn.jboss.org/repos/seam/branches/enterprise/WFK-2_0/jboss-seam-gen/dist/build-scripts/deployed-jars-war.list misses knowledge-api.jar and http://anonsvn.jboss.org/repos/seam/branches/enterprise/WFK-2_0/jboss-seam-gen/dist/build-scripts/deployed-jars-ear.list has got it.

I will create the standalone issue
Comment 23 JBoss JIRA Server 2012-06-12 13:42:53 EDT
Daniel Hinojosa <dhinojosa@evolutionnext.com> made a comment on jira JBIDE-11490

Searched through the project and there is no mention of the word "knowledge" anywhere.  I created the war list and the ear list based strictly on the dependencies.  I assume that knowledge-api will need to be placed in the jboss-seam's project's web.xml.
Comment 24 JBoss JIRA Server 2012-06-12 14:06:38 EDT
Daniel Hinojosa <dhinojosa@evolutionnext.com> made a comment on jira JBIDE-11490

Assign the ticket to me Marek, I have it in now in the project, and will commit.
Comment 25 JBoss JIRA Server 2012-06-14 02:45:55 EDT
Marek Novotny <mnovotny@redhat.com> made a comment on jira JBIDE-11490

This issue is owned by JBTools team - I can't assign it to you. What I meant by missing knowledge-api.jar is dependency of Drools integration in version 5.2.2 which we upgraded in different version of Seam in WFK product. That is the content of my comment https://issues.jboss.org/browse/JBIDE-11490?focusedCommentId=12700721&page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel#comment-12700721. It is another issue tracker which notifies/spams the community JIRA.

Seam 2.3.0.Beta2-SNAPSHOT is not affected as it has got still Drools 5.1.1 and there is drools-api instead of knowledge-api. Just to be more clear Drools 5.2 renamed drools-api to knowledge-api ;-).
Comment 26 JBoss JIRA Server 2012-06-21 09:22:34 EDT
Tomas Remes <tremes@redhat.com> updated the status of jira JBSEAM-4918 to Reopened
Comment 27 JBoss JIRA Server 2012-06-21 09:22:34 EDT
Tomas Remes <tremes@redhat.com> made a comment on jira JBSEAM-4918

Hey Dan!
My generated EAR still didn't get deployed in Eclipse with JBT, because it is missing META-INF/jboss-deployment-structure.xml. The reason is that project generated build.xml is missing following line (on 262):
{noformat}
<include name="jboss-deployment-structure.xml"/>
{noformat}

I am using locally built CR1-SNAPSHOT dist from 2012-06-21.
Comment 28 JBoss JIRA Server 2012-06-21 12:54:18 EDT
Daniel Hinojosa <dhinojosa@evolutionnext.com> updated the status of jira JBSEAM-4918 to Resolved
Comment 29 JBoss JIRA Server 2012-06-21 12:54:18 EDT
Daniel Hinojosa <dhinojosa@evolutionnext.com> made a comment on jira JBSEAM-4918

Thanks Tomas, 

Submitted the fix.
Comment 30 JBoss JIRA Server 2012-07-25 07:40:07 EDT
Tomas Remes <tremes@redhat.com> updated the status of jira JBSEAM-4960 to Reopened
Comment 31 JBoss JIRA Server 2012-07-25 07:40:07 EDT
Tomas Remes <tremes@redhat.com> made a comment on jira JBSEAM-4960

This problems is occuring again. Using Seam dist SNAPSHOT from 2012-07-23 gives in JBDS 5.0.1 following classpath errors for missing libraries: 

lib/testng-jdk15.jar
lib/jboss-jsf-api_2.1_spec.jar
lib/jboss-deployers-core-spi.jar
lib/jboss-deployers-client-spi.jar
lib/hsqldb.jar
lib/cglib-nodep.jar
Comment 32 JBoss JIRA Server 2012-07-25 07:40:47 EDT
Tomas Remes <tremes@redhat.com> made a comment on jira JBSEAM-4960

This problem is occuring again. Using Seam dist SNAPSHOT from 2012-07-23 gives in JBDS 5.0.1 following classpath errors for missing libraries: 

lib/testng-jdk15.jar
lib/jboss-jsf-api_2.1_spec.jar
lib/jboss-deployers-core-spi.jar
lib/jboss-deployers-client-spi.jar
lib/hsqldb.jar
lib/cglib-nodep.jar
Comment 33 JBoss JIRA Server 2012-07-25 08:16:32 EDT
Tomas Remes <tremes@redhat.com> updated the status of jira JBSEAM-4960 to Resolved
Comment 34 JBoss JIRA Server 2012-07-25 08:16:32 EDT
Tomas Remes <tremes@redhat.com> made a comment on jira JBSEAM-4960

Sorry, that was my mistake. Seam dist zip was not up to date.
Comment 35 JBoss JIRA Server 2012-07-26 06:43:53 EDT
Tomas Remes <tremes@redhat.com> updated the status of jira JBSEAM-4960 to Reopened
Comment 36 JBoss JIRA Server 2012-07-26 06:45:18 EDT
Tomas Remes <tremes@redhat.com> made a comment on jira JBSEAM-4960

I have been confused by Seam dist zip's, but above mentioned libraries are really missing after import to JBDS.
Comment 37 JBoss JIRA Server 2012-08-15 04:48:29 EDT
Marek Novotny <mnovotny@redhat.com> made a comment on jira JBSEAM-4960

I believe these are not needed:

lib/jboss-deployers-core-spi.jar - this is for JBoss Embedded usage
lib/jboss-deployers-client-spi.jar - this is for JBoss Embedded usage
lib/hsqldb.jar - we should use H2 as JBoss AS7

We should remove them and try if all works as before.
Comment 38 JBoss JIRA Server 2012-08-23 08:20:02 EDT
Tomas Remes <tremes@redhat.com> made a comment on jira JBIDE-11490

I had to add following jars (EAR/lib and WAR/WEB-INF/lib) and - drools-core-5.3.3.Final.jar, guava-12.0.jar, jboss-el-1.0_02.CR6.jar to successfully deploy (7.1.1) Seam 2.3 project created in JBDS 5.0.1. I used CR1-SNAPSHOT dist available at http://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/Seam%20Framework/job/Seam-2.3.X-dist-nightly/
Comment 39 JBoss JIRA Server 2012-08-23 08:23:26 EDT
Tomas Remes <tremes@redhat.com> made a comment on jira JBIDE-11490

I had to add following jars (EAR/lib and WAR/WEB-INF/lib) - drools-core-5.3.3.Final.jar, guava-12.0.jar, jboss-el-1.0_02.CR6.jar to successfully deploy (7.1.1) Seam 2.3 project created in JBDS 5.0.1. I used CR1-SNAPSHOT dist available at http://jenkins.mw.lab.eng.bos.redhat.com/hudson/view/Seam%20Framework/job/Seam-2.3.X-dist-nightly/
Comment 40 JBoss JIRA Server 2012-08-23 08:33:13 EDT
Marek Novotny <mnovotny@redhat.com> made a comment on jira JBIDE-11490

just heads up. I have upgraded Drools to 5.3.3 sometime ago also in community Seam 2.3, so there has to be changes like replacement of drools-api.jar with knowledge-api.jar

Note You need to log in before you can comment on or make changes to this bug.