Bug 828829 - Kernel panic at shutdown - cannot detach DM devices
Kernel panic at shutdown - cannot detach DM devices
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 08:44 EDT by Zoltan Hoppar
Modified: 2013-01-02 13:11 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-02 13:11:16 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Zoltan Hoppar 2012-06-05 08:44:54 EDT
Description of problem:
When I try to logout/turn off from menu of Gnome 3 - shutdown can't complete fully. It tries to detach 3 times DM devices, and freezing fully in kernel panic.

Version-Release number of selected component (if applicable):
kernel 3.3.7-1.fc17.x86_64 #1 SMP Mon May 21 22:32:19 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Machine: Hp 4515s

How reproducible:
Always

Steps to Reproduce:
1. Make an logout, and start shutdown by the turn of icon
2. Send out the usual SIGTERM, SIGKILL, and unmounting file systems till reaching the DM devices. Tries to unmount 3 times, but unsuccessfully, 
3. After this the system drops an error message - cannot open an shared lib at /bin/sh libbdl.so.2 - no such file or dir
4. Freezing in kernel panic - Panic+0xba/0x1c6, kernel not tainted 3.3.7-1. 
5. I never can't shut down my machine properly, I have to force with power button
  
Actual results:
Shut down not complete, machine halts in kernel panic.

Expected results:
Proper shutdown.

Additional info:
Looks like for me is an earlier issue at bugzilla #657497. But still can't turn off properly my machine.
Comment 1 Justin M. Forbes 2012-09-11 11:41:42 EDT
Is this still happening with 3.5.3 kernels in updates?
Comment 2 Zoltan Hoppar 2012-09-11 12:09:41 EDT
No, not anymore, with the latest kernel it has disappeared. However, I don't know it's related or not, but randomly freezing out the touchpad in my machine, or the ACPI part. As I checked in logfiles, the system somtimes forgets to configure properly the second core in my AMD processor. That means two things. One is overheats my machine (till 78C - after shuts down), and the second is briefly appears an error message that [firmware bug] try to use lapic 500 in vector 'hex-numbers'. How can I help you guys to finish this bug in my machine too?

Note You need to log in before you can comment on or make changes to this bug.