Bug 828892 - aeolus-configure fails to find aeolus::conductor class if puppet 2.7 is already installed
aeolus-configure fails to find aeolus::conductor class if puppet 2.7 is alrea...
Status: CLOSED UPSTREAM
Product: CloudForms Cloud Engine
Classification: Red Hat
Component: aeolus-configure (Show other bugs)
1.0.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: John Eckersberg
Rehana
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 10:40 EDT by Ricky Nelson
Modified: 2013-01-29 11:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-29 11:11:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch generated by the fix-autoloader (54.42 KB, application/octet-stream)
2012-06-21 10:56 EDT, Marek Mahut
no flags Details

  None (edit)
Description Ricky Nelson 2012-06-05 10:40:47 EDT
During installation, aeolus-configure is not able to locate aeolus::conductor class. This is due to puppet 2.7 already being installed on the system. Puppet 2.7 uses autoloader while this feature is missing under 2.6.

 puppet >= 2.6.6 is needed by (installed) aeolus-configure-2.5.3-1.el6.noarch

If a rebase of puppet to 2.7 is coming, then that would take care of this. Otherwise, possibly updating the spec file to fail to install if puppet 2.7 is already installed.
Comment 1 Mike Orazi 2012-06-20 13:23:28 EDT
A significant amount of work went into reworking the manifest to make them 2.7 friendly upstream.
Comment 2 Marek Mahut 2012-06-21 10:56:29 EDT
Created attachment 593472 [details]
patch generated by the fix-autoloader
Comment 4 John Eckersberg 2013-01-29 11:11:31 EST
This is fixed upstream and will be included for CF 2.0 when it gets rebased.

Note You need to log in before you can comment on or make changes to this bug.