Bug 8289 - With SCSI: Strange `ls' behavior related to lockup?
With SCSI: Strange `ls' behavior related to lockup?
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: installer (Show other bugs)
6.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Jay Turner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-01-08 04:15 EST by David Meyer
Modified: 2015-01-07 18:40 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-09-19 18:30:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Meyer 2000-01-08 04:15:46 EST
I am running a system with 2 IDE drives and 1 SCSI drive, the SCSI one
being the main one. (/dev/sda)..I do expert install on the bootnet disk
(for FTP) and for some odd reason after getting package info the computer
stalls for 20 minutes and then continues to let me select the packages,
and then proceeds normally until it begins installing the packages, when
it stalls again and never comes back. I went to the vt with the shell and
explored and found that when in /mnt/sysimage I do an `ls` and I get an
infinite listing of just 'dev', in 2 columns. I press Ctrl-C to abort and
do an 'ls -a' and I get an infinite listing of just '.' in 2 columns, and
I do an 'ls -la', and I get a normal listing of the files that terminates
properly. I wonder, could the installer in the first vt have stalled
because its reading a never ending dir listing of dev's ??? Is this
perhaps a bug in SCSI support? (since /mnt/sysimage is /dev/sda1) Also I
notice I can't install LILO on the SCSI's MBR, and the disk selection
guide was very difficult to convince not to do stuff with my IDE drives
(which I hope it didn't since they contain all my important data).
Comment 1 Jay Turner 2000-02-14 12:34:59 EST
There are some known issues with "ls" in portions of the install.  We are
actually making use of a boiled-down ls command.  It needs some work, so we are
working on that.
Comment 2 Michael Fulbright 2000-09-19 18:30:13 EDT
If you still see this problem with the current Red Hat release please reopen
this bug. We have changed
several things that may have helped.

Note You need to log in before you can comment on or make changes to this bug.