Bug 828931 - Network Manager does not provide UI to enable IPv6 privacy options.
Network Manager does not provide UI to enable IPv6 privacy options.
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: NetworkManager (Show other bugs)
17
Unspecified Unspecified
unspecified Severity medium
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
:
: 790610 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 11:12 EDT by William Brown
Modified: 2013-05-10 03:19 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-10 03:19:19 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 633233 None None None 2012-07-27 03:45:49 EDT

  None (edit)
Description William Brown 2012-06-05 11:12:23 EDT
Description of problem:

Network manager should include an option to toggle the state of IPv6 privacy extensions on a device. This will make it easier for users to gain access to this (quite important) feature of ipv6 on client machines. This should default to "on" in a Desktop installation. Additionally, this would be useful to configure from the relevant ifcfg-<dev> scripts via a toggle such as "IPV6PRIVACY=yes"
Comment 1 Jirka Klimes 2012-07-27 03:45:49 EDT
There's a patch in upstream bugzilla (see external trackers).
Comment 2 David Woodhouse 2012-08-23 10:24:07 EDT
*** Bug 790610 has been marked as a duplicate of this bug. ***
Comment 3 David Woodhouse 2012-08-23 10:25:56 EDT
Privacy addressing gives little benefit except to let the paranoid tinfoil-hat wearers sleep better at night. It breaks reverse DNS on outbound connections, and causes other connectivity issues when a temporary address is not regained after a temporary wireless drop, etc.

Please do *not* enable it by default, but by all means have a UI option for the rare users who actually want it.
Comment 4 William Brown 2012-08-23 20:02:28 EDT
I do not want this enabled by default - I am fully aware of the "fun" it creates for servers etc. I would just like a UI to provide this option.

Note You need to log in before you can comment on or make changes to this bug.