Bug 828971 - kickstart doesn't work with F17 guests -> unable to process initqueue dracut Warning: Unable to process initqueue
kickstart doesn't work with F17 guests -> unable to process initqueue dracut ...
Status: CLOSED DUPLICATE of bug 828589
Product: Fedora
Classification: Fedora
Component: dracut (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: dracut-maint
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 12:22 EDT by Steven Dake
Modified: 2016-04-26 19:01 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 16:38:25 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
oz tdl file for F17 (1.08 KB, text/plain)
2012-06-05 12:24 EDT, Steven Dake
no flags Details
fedora 17 kickstart file generated by installing F17 in a virtual machine (673 bytes, text/plain)
2012-06-05 12:26 EDT, Steven Dake
no flags Details
actual f17 kickstart file used in oz (last one was wrong repo) (1.03 KB, text/plain)
2012-06-05 12:46 EDT, Steven Dake
no flags Details

  None (edit)
Description Steven Dake 2012-06-05 12:22:54 EDT
Description of problem:
I have added F17 support to oz, which is an image builder for virtual machines.  I installed Fedora 17 and used the generated kickstart file to seed the kickstart file for oz.  I didn't modify the kickstart file created from the install at all.

To try oz, pull the repo:
git clone git://github.com/sdake/oz.git
make rpm
rpm -ivh (the rpm created by oz)

Running oz creation with the kickstart file (oz/oz/auto/fedora-17-jeos.ks - attached) results in failure.

Version-Release number of selected component (if applicable):
Fedora 17 iso

How reproducible:
100%

Steps to Reproduce:
Use F16 as a the base OS

1. install updated OZ from above forked repo
2. Put the iso image file in /var/lib/libvirt/images
2. run oz-install F17-x86_64-cfntools-jeos.tdl
3. open virtual machine manager and watch the install fail
  
Actual results:
booting fails with:
dracut Warning: Unable to process initqueue
dracut Warning: /dev/root does not exist
Dropping to debug shell

Expected results:
oz install works properly

Additional info:

I used the kickstart that was created from installing a f17 using virtual machine manager.

If the kickstart generated by the install isn't correct, could I get some guidance for a proper kickstart file?
Comment 1 Steven Dake 2012-06-05 12:24:05 EDT
Created attachment 589572 [details]
oz tdl file for F17
Comment 2 Steven Dake 2012-06-05 12:26:16 EDT
Created attachment 589573 [details]
fedora 17 kickstart file generated by installing F17 in a virtual machine
Comment 3 Steven Dake 2012-06-05 12:46:06 EDT
Created attachment 589581 [details]
actual f17 kickstart file used in oz (last one was wrong repo)
Comment 4 Steven Dake 2012-06-07 16:14:24 EDT
This may be user error, but is definitely a change in functionality from F16->F17.  Documenting in bugzilla so others that run into this problem understand the problem.

Previously oz used the kernel command ks=cdrom:/ks.cfg.  Reading the kickstart docs, the correct syntax is ks=cdrom:/dev/cdrom:/ks.cfg.  Changing to the proper syntax makes the software work, although other software may depend on the previous behavior where just cdrom:/ks.cfg worked properly.
Comment 5 Steven Dake 2012-06-07 16:38:25 EDT

*** This bug has been marked as a duplicate of bug 828589 ***

Note You need to log in before you can comment on or make changes to this bug.