Bug 828977 - Sync silently "cancels" on some (very large?) repos
Sync silently "cancels" on some (very large?) repos
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Unspecified
unspecified Severity high (vote)
: Unspecified
: --
Assigned To: Mike McCune
Kedar Bidarkar
: Triaged, ZStream
Depends On: 818204
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 13:03 EDT by Chris Pelland
Modified: 2014-09-18 11:31 EDT (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Memory consumption issues for createrepo caused synchronization of large repositories to fail. This update provides a new version of createrepo that switches XML files for SQLite DBs for --update. This fixes the memory consumption issues.
Story Points: ---
Clone Of: 818204
Environment:
Last Closed: 2012-07-10 03:25:36 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 4 Dan Macpherson 2012-06-13 12:54:04 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Memory consumption issues for createrepo caused synchronization of large repositories to fail. This update provides a new version of createrepo that switches XML files for SQLite DBs for --update. This fixes the memory consumption issues.
Comment 5 Kedar Bidarkar 2012-06-19 05:07:34 EDT
DashBoard Sync Overview shows, the sync has completed "100%", But

Sync Mgmt does not show, the status as "Sync Complete"

From the above 2 different states, I feel there is some inconsistency for the state of syncs for very large repos.

I will be attaching the screen-shots shortly.

Build : 2012-06-18.1/  
RAM : 2GB
SWAP : 2GB
REPO synced : Single repo F17 (27.1 GB)
Comment 12 Kedar Bidarkar 2012-06-20 05:31:44 EDT
Agreed this issues are not worth z-stream, may be good to have a track for these issues with a new bug and also update the actual Bug 818204.
Comment 14 Og Maciel 2012-06-20 11:13:42 EDT
Verified by QA.

* candlepin-0.6.5-1.el6_2.noarch
* candlepin-tomcat6-0.6.5-1.el6_2.noarch
* katello-0.1.317-1.el6_2.noarch
* katello-all-0.1.317-1.el6_2.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.0.7-1.el6_3.noarch
* katello-cli-0.1.111-1.el6_2.noarch
* katello-cli-common-0.1.111-1.el6_2.noarch
* katello-common-0.1.317-1.el6_2.noarch
* katello-configure-0.1.110-1.el6_3.noarch
* katello-glue-candlepin-0.1.317-1.el6_2.noarch
* katello-glue-foreman-0.1.317-1.el6_2.noarch
* katello-glue-pulp-0.1.317-1.el6_2.noarch
* katello-qpid-broker-key-pair-1.0-1.noarch
* katello-qpid-client-key-pair-1.0-1.noarch
* katello-selinux-0.1.10-1.el6.noarch
* pulp-1.0.4-1.el6.noarch
* pulp-common-1.0.4-1.el6.noarch
* pulp-selinux-server-1.0.4-1.el6.noarch
Comment 16 errata-xmlrpc 2012-07-10 03:25:36 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1062.html

Note You need to log in before you can comment on or make changes to this bug.