This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 828981 - condor resource agent has incorrect timeout values in metadata
condor resource agent has incorrect timeout values in metadata
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: condor (Show other bugs)
Development
Unspecified Unspecified
low Severity low
: 2.3
: ---
Assigned To: Robert Rati
Tomas Rusnak
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 13:19 EDT by Robert Rati
Modified: 2013-03-19 12:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: condor-7.8.2-0.3
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-19 12:39:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Rati 2012-06-05 13:19:45 EDT
Description of problem:
The condor RA produces metadata that only provides a timeout of 5 seconds for actions like start, stop, and restart.  For start this isn't as big a beal since the daemon start is a bit of fire and forget, but stop allows a 600 second timeout in case of a slow shutdown.  In the case of a long shutdown, the rgmanager will assume failure after 5 seconds rather than allowing the RA to complete the shutdown process.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Robert Rati 2012-06-20 13:32:41 EDT
Corrected the timeout values in the metadata.

Fixed upstream on:
V7_6-branch
Comment 4 Martin Kudlej 2012-08-21 05:38:18 EDT
Where can I find Condor RA metadata? How can I test that timeouts have changed?
Comment 5 Robert Rati 2012-08-21 08:04:34 EDT
The RA is like an initscript, so run "condor meta-data" to get the metadata.
Comment 6 Eric Sammons 2012-10-03 10:06:21 EDT
/usr/share/cluster/condor.sh
Comment 10 Tomas Rusnak 2013-01-17 10:16:20 EST
# /usr/share/cluster/condor.sh meta-data
<?xml version="1.0"?>
<!DOCTYPE resource-agent SYSTEM "ra-api-1-modified.dtd">
<resource-agent version="rgmanager 2.0" name="condor">
  <version>1.0</version>

  <longdesc lang="en">
    condor resource agent
  </longdesc>
  <shortdesc lang="en">
    condor resource agent
  </shortdesc>

  <parameters>
    <parameter name="name" unique="1" primary="1">
    <longdesc lang="en">
      The name passed to the condor subsystem type
    </longdesc>
    <shortdesc lang="en">
      condor subsystem name
    </shortdesc>
    <content type="string"/>
    </parameter>

    <parameter name="type" required="1">
    <longdesc lang="en">
      The type of condor subsystem
    </longdesc>
    <shortdesc lang="en">
      condor subsystem type
    </shortdesc>
    <content type="string"/>
    </parameter>
  </parameters>

  <actions>
    <action name="start" timeout="15"/>
    <action name="stop" timeout="605"/>
    <action name="recover" timeout="630"/>
    <action name="monitor" interval="30" timeout="5"/>
    <action name="status" interval="30" timeout="5"/>
    <action name="meta-data" timeout="5"/>
    <action name="validate-all" timeout="5"/>
  </actions>
</resource-agent>

Metadata updated.
condor-cluster-resource-agent-7.8.8-0.1.el6

>>> VERIFIED

Note You need to log in before you can comment on or make changes to this bug.