Bug 828982 - keyboard shortcuts settings screen does not show all virtual desktops
keyboard shortcuts settings screen does not show all virtual desktops
Status: CLOSED DUPLICATE of bug 826024
Product: Fedora
Classification: Fedora
Component: gnome-settings-daemon (Show other bugs)
17
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 13:20 EDT by Patrick C. F. Ernzer
Modified: 2012-06-05 13:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-05 13:25:08 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Patrick C. F. Ernzer 2012-06-05 13:20:47 EDT
Description of problem:
While I have 8 virtual desktops, the Keyboard Shortcuts dialog only offers me to assign shortcuts for 'Switch to workspace N' with N ranging from 1 through 4
AFAIR this worked just fine in F16 and older

Version-Release number of selected component (if applicable):
Fedora 17 (not sure what componet the settings dialog is part of)

How reproducible:
always

Steps to Reproduce:
0. Be in forced fallback mode (this machie is slow and often used through VNC, thus I have no interest at all in the fancy mode)
1. have the Workspace Switcher visible in your taskbar
2. right click Workspace Switcher, select Preferences
3. set a number of workspaces that is > 4 (I have 8)
4. open System Settings, Keyboard, Shortcuts, Navigation

Actual results:
ability to set shortcuts for "Switch to workspace N" and "Move window to workspace N" with N between 1 and 4

Expected results:
ability to set shortcuts for "Switch to workspace N" and "Move window to workspace N" with N going from 1 to the number I set as amount of workspaces used in the Workspace Switcher

Additional info:
for others running into this (and with big kudos to mclasen), you can work around this as follows
$ gsettings list-recursively org.gnome.desktop.wm.keybindings #to see them
[...]
org.gnome.desktop.wm.keybindings switch-to-workspace-4 ['<Alt>4']
org.gnome.desktop.wm.keybindings switch-to-workspace-5 @as []
[...]
$ gsettings set org.gnome.desktop.wm.keybindings switch-to-workspace-5 "['<Alt>5']"
Comment 1 Patrick C. F. Ernzer 2012-06-05 13:25:08 EDT

*** This bug has been marked as a duplicate of bug 826024 ***

Note You need to log in before you can comment on or make changes to this bug.