This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 828989 - [pt_BR] failed pofilter urls test for subscription-manager translations
[pt_BR] failed pofilter urls test for subscription-manager translations
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.9
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.9
Assigned To: Bryan Kearney
Entitlement Bugs
: i18n, Translation
Depends On:
Blocks: 771748
  Show dependency treegraph
 
Reported: 2012-06-05 13:34 EDT by Sharath Dwaral
Modified: 2015-03-22 21:13 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-07 22:54:10 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Sharath Dwaral 2012-06-05 13:34:04 EDT
Description of problem:
The gnome urls were not properly translated for 'pt_BR' language.  Sample output is shown below, 


Version-Release number of selected component (if applicable):
[root@fsharath-rhel63server ~]# rpm -q subscription-manager
subscription-manager-0.99.19-1.el6.x86_64

How reproducible:

[root@fsharath-rhel63server ~]# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo -o /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
[root@fsharath-rhel63server ~]# pofilter --gnome -t urls /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
processing 1 files...
msgid ""
msgstr ""
"Project-Id-Version: pt_BR\n"
"Report-Msgid-Bugs-To: \n"
"POT-Creation-Date: 2012-05-16 08:40-0400\n"
"PO-Revision-Date: 2012-04-12 09:51-0400\n"
"Last-Translator: gcintra <gcintra@fedoraproject.org>\n"
"Language-Team: <en@li.org>\n"
"Language: pt-BR\n"
"MIME-Version: 1.0\n"
"Content-Type: text/plain; charset=UTF-8\n"
"Content-Transfer-Encoding: 8bit\n"
"Plural-Forms: nplurals=2; plural=(n != 1)\n"
"X-Generator: Zanata 1.5.0\n"

# (pofilter) urls: Different URLs
msgid "To learn more about RHN registration and technologies please consult this Knowledge Base Article: https://access.redhat.com/kb/docs/DOC-45563"
msgstr "Para aprender mais sobre como se registrar no RHN e sobre as tecnologias, por favor consulte este Artigo de Base de Conhecimento: //access.redhat.com/kb/docs/DOC-45563"


Steps to Reproduce:

Actual results:
Shown above

Expected results:

msgid "To learn more about RHN registration and technologies please consult this Knowledge Base Article: https://access.redhat.com/kb/docs/DOC-45563"
>msgstr "Para aprender mais sobre como se registrar no RHN e sobre as tecnologias, por favor consulte este Artigo de Base de Conhecimento: https://access.redhat.com/kb/docs/DOC-45563"


Additional info:

http://translate.sourceforge.net/wiki/toolkit/pofilter_tests#urls
Comment 3 Alex Wood 2012-06-18 13:02:14 EDT
commit 7db69464adb5b50dcf1f7b63cf0c9580ced11a87
Refs: subscription-manager-1.0.2-1-86-g7db6946
Author:     Bryan Kearney <bkearney@redhat.com>
AuthorDate: Tue Jun 5 16:52:02 2012 -0400
Commit:     Bryan Kearney <bkearney@redhat.com>
CommitDate: Wed Jun 6 15:38:39 2012 -0400

    828989: Fix the access url
Comment 4 RHEL Product and Program Management 2012-06-18 13:07:58 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 5 Glaucia Cintra 2012-06-25 22:45:25 EDT
Bug fixed as requested on expected results for pt-br.
Comment 7 Sharath Dwaral 2012-07-12 16:10:16 EDT
Version:
# rpm -qa | egrep "subscription-manager|python-rhsm"
subscription-manager-gui-1.0.9-1.git.4.59ef2fe.el5
python-rhsm-1.0.3-1.git.2.47dc8f4.el5
subscription-manager-migration-data-1.11.2.2-1.git.0.2eea155.el5
subscription-manager-migration-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-firstboot-1.0.9-1.git.4.59ef2fe.el5
subscription-manager-1.0.9-1.git.4.59ef2fe.el5

Verification:
# msgunfmt --no-wrap /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.mo -o /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.po
[root@fsharath-rhel59server ~]# pofilter --gnome -t urls /usr/share/locale/pt_BR/LC_MESSAGES/rhsm.poprocessing 1 files...
[###########################################] 100%

Moving bug to VERIFIED
Comment 9 errata-xmlrpc 2013-01-07 22:54:10 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0033.html

Note You need to log in before you can comment on or make changes to this bug.