Bug 829013 - [abrt] epiphany-3.4.1-2.fc17: __GI_raise: Process /usr/bin/epiphany was killed by signal 6 (SIGABRT)
[abrt] epiphany-3.4.1-2.fc17: __GI_raise: Process /usr/bin/epiphany was kille...
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: epiphany (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Peter Hatina
Fedora Extras Quality Assurance
abrt_hash:cc85eb723006bccec1f2f14c202...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 14:57 EDT by gabe@codehaus.org
Modified: 2016-05-31 21:31 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-01-09 03:12:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (15.12 KB, text/plain)
2012-06-05 14:57 EDT, gabe@codehaus.org
no flags Details
File: build_ids (6.13 KB, text/plain)
2012-06-05 14:57 EDT, gabe@codehaus.org
no flags Details
File: maps (82.49 KB, text/plain)
2012-06-05 14:57 EDT, gabe@codehaus.org
no flags Details
File: backtrace (34.92 KB, text/plain)
2012-06-05 14:57 EDT, gabe@codehaus.org
no flags Details

  None (edit)
Description gabe@codehaus.org 2012-06-05 14:57:15 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        epiphany
comment:        Visited cnn.com. Got a dialog saying IcedTea could not run /usr/bin/java. Epiphany then crashed.
crash_function: __GI_raise
executable:     /usr/bin/epiphany
kernel:         3.3.7-1.fc17.x86_64
pid:            3168
time:           Tue 05 Jun 2012 11:55:53 AM PDT
uid:            1000

backtrace:      Text file, 35760 bytes
build_ids:      Text file, 6273 bytes
dso_list:       Text file, 15479 bytes
maps:           Text file, 84473 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/gbauman/2

core_backtrace:
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x35965 raise libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x37118 abort libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x2e6e2 __assert_fail_base libc.so.6 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x2e792 __assert_fail libc.so.6 -
:696b4061511c61958e3188706939a80b90879553 0x116dc - npwrapper.libtotem-gmp-plugin.so -
:696b4061511c61958e3188706939a80b90879553 0x116ed - npwrapper.libtotem-gmp-plugin.so -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x476e5 g_main_context_dispatch libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47a18 - libglib-2.0.so.0 -
:e5945f7dae3fc83ad499da1ea5a464bfa0e68202 0x47ad4 g_main_context_iteration libglib-2.0.so.0 -
:6ffd106c467fc2bbbe04c9509d66f7d97d2a751f 0x97dec g_application_run libgio-2.0.so.0 -
:1ee16b6f557e6ec3341b012530fbecc00f9cb030 0x2f238 main [exe] -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=monolith.catacomb.lan
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:GNOME_KEYRING_CONTROL=/run/user/gbauman/keyring-adMj8P
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=gbauman
:USERNAME=gbauman
:MAIL=/var/spool/mail/gbauman
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/gbauman/.local/bin:/home/gbauman/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1147
:LANG=en_US.utf8
:GDM_LANG=en_US.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/gbauman
:SHLVL=1
:LOGNAME=gbauman
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-Wv533NR1PF,guid=2258016404ec9ae5825adc660000001d
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/gbauman
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-gbauman-3XmWPa/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1152,unix/unix:/tmp/.ICE-unix/1152
:SSH_AUTH_SOCK=/run/user/gbauman/keyring-adMj8P/ssh
:GPG_AGENT_INFO=/run/user/gbauman/keyring-adMj8P/gpg:0:1
:LC_TIME=en_CA.utf8
:LC_NUMERIC=en_CA.utf8
:LC_MONETARY=en_CA.utf8
:LC_MEASUREMENT=en_CA.utf8
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/epiphany.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=3168
:DESKTOP_STARTUP_ID=gnome-shell-1365-monolith.catacomb.lan-epiphany-7_TIME2407817

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 128028               processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       128028               128028               signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/dev/null
:pos:	0
:flags:	0100002
:2:/dev/null
:pos:	0
:flags:	0100002
:3:socket:[33692]
:pos:	0
:flags:	02004002
:4:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:5:socket:[35245]
:pos:	0
:flags:	02004002
:6:socket:[34614]
:pos:	0
:flags:	02000002
:7:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:8:socket:[33695]
:pos:	0
:flags:	02004002
:9:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:10:anon_inode:inotify
:pos:	0
:flags:	02004000
:11:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:12:/home/gbauman/.gnome2/epiphany/ephy-history.db
:pos:	6144
:flags:	02100002
:13:socket:[34616]
:pos:	0
:flags:	02004002
:14:/home/gbauman/.local/share/epiphany/WebpageIcons.db
:pos:	40
:flags:	02100002
:15:/home/gbauman/.local/share/gvfs-metadata/home
:pos:	0
:flags:	0100000
:16:/home/gbauman/.local/share/gvfs-metadata/home-c5db45bd.log
:pos:	0
:flags:	0100000
:17:socket:[36346]
:pos:	0
:flags:	02004002
:18:socket:[34618]
:pos:	0
:flags:	02004002
:19:/dev/urandom
:pos:	0
:flags:	02100000
:20:socket:[35247]
:pos:	0
:flags:	02000002
:21:/home/gbauman/.gnome2/epiphany/cookies.sqlite
:pos:	14336
:flags:	02100002
:22:socket:[35248]
:pos:	0
:flags:	04002
:23:socket:[36347]
:pos:	0
:flags:	02004002
:24:socket:[36350]
:pos:	0
:flags:	02004002
:25:socket:[36351]
:pos:	0
:flags:	02004002
:26:socket:[34645]
:pos:	0
:flags:	02004002
:27:socket:[34651]
:pos:	0
:flags:	02004002
:28:/home/gbauman/.cache/epiphany/.goutputstream-XZ9AFW
:pos:	547310
:flags:	0100001
:29:socket:[36352]
:pos:	0
:flags:	02004002
:30:/tmp/debug.log
:pos:	0
:flags:	0102001
:31:socket:[33723]
:pos:	0
:flags:	02004002
:32:socket:[34658]
:pos:	0
:flags:	02004002
:33:socket:[35374]
:pos:	0
:flags:	02004002
:34:socket:[35379]
:pos:	0
:flags:	02004002
:35:socket:[34683]
:pos:	0
:flags:	02004002
:36:socket:[34689]
:pos:	0
:flags:	02004002
:37:socket:[34696]
:pos:	0
:flags:	02004002
:38:/home/gbauman/.config/google-googletalkplugin/gtbplugin.log
:pos:	108
:flags:	0100001
:39:socket:[36416]
:pos:	0
:flags:	02004002
:40:socket:[35528]
:pos:	0
:flags:	02004002
:41:socket:[36450]
:pos:	0
:flags:	02004002
:42:socket:[36456]
:pos:	0
:flags:	02004002
:43:socket:[36469]
:pos:	0
:flags:	02004002
:44:socket:[38044]
:pos:	0
:flags:	02004002

var_log_messages:
:Jun  5 11:51:13 monolith abrt[2924]: Saved core dump of pid 1999 (/usr/bin/epiphany) to /var/spool/abrt/ccpp-2012-06-05-11:51:11-1999 (1346592768 bytes)
:Jun  5 11:55:55 monolith abrt[3499]: Saved core dump of pid 3168 (/usr/bin/epiphany) to /var/spool/abrt/ccpp-2012-06-05-11:55:53-3168 (1246257152 bytes)
Comment 1 gabe@codehaus.org 2012-06-05 14:57:20 EDT
Created attachment 589615 [details]
File: dso_list
Comment 2 gabe@codehaus.org 2012-06-05 14:57:22 EDT
Created attachment 589616 [details]
File: build_ids
Comment 3 gabe@codehaus.org 2012-06-05 14:57:24 EDT
Created attachment 589617 [details]
File: maps
Comment 4 gabe@codehaus.org 2012-06-05 14:57:27 EDT
Created attachment 589618 [details]
File: backtrace
Comment 5 Peter Hatina 2012-06-11 05:20:59 EDT
Issue caused by unmatching gtk+ versions used in IcedTeaPlugin and epiphany. Please, use nspluginwrapper for proper usage of java plugins in epiphany.

For more info, how to do this, have a look at https://bugzilla.redhat.com/show_bug.cgi?id=742584

Note You need to log in before you can comment on or make changes to this bug.