Bug 829020 - Disable llvmpipe swrast for ARM
Disable llvmpipe swrast for ARM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: mesa (Show other bugs)
17
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-06-05 15:22 EDT by Daniel Drake
Modified: 2012-06-07 15:29 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 15:29:48 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Drake 2012-06-05 15:22:29 EDT
Apps that use clutter (or OpenGL) currently crash on ARM with messages like:

LLVM ERROR: Not supported instr %R0<def> = LEApcrel <cp#1>, pred:14, pred:%nore

e.g. glxgears, totem


This is because mesa is built with llvmpipe for ARM, but llvm for ARM is broken at the moment.

ppc* already disables llvmpipe within mesa.spec for similar reasons. Can ARM be added to this exception case too?

That way the non-llvm swrast will be built, and apps that use clutter/OpenGL can run (albeit slowly!).
Comment 1 Adam Jackson 2012-06-07 15:29:48 EDT
Done in F17 and master branches.

Note You need to log in before you can comment on or make changes to this bug.