Bug 829022 - No tilda (~) character on gnome 3 shell accessibility keyboard
No tilda (~) character on gnome 3 shell accessibility keyboard
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: caribou (Show other bugs)
rawhide
i686 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Parag Nemade
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 15:27 EDT by pscottdv
Modified: 2013-03-27 06:19 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-27 06:19:46 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 680556 None None None 2012-10-09 22:32:37 EDT

  None (edit)
Description pscottdv 2012-06-05 15:27:33 EDT
Description of problem:
caribou on-screen keyboard does not allow entry of the tilda (~) character.

Version-Release number of selected component (if applicable):
0.4.2-1.fc17 - Not unique to this version--earlier versions had same problem

How reproducible:
Very

Steps to Reproduce:
1. Try to find a tilda on the on-screen keyboard
2. You can't
3. Cry in frustration because you cannot enter the tilda (~) in your password on your keyboard-less, pen-based computer therby gaining access to Fedora goodness.
  
Actual results:
Tears of frustration

Expected results:
Happiness following entry of tilda (~) character

Additional info:
Comment 1 pscottdv 2012-07-16 12:13:26 EDT
You know, the tilda character gets used a lot in Unix-like systems.  Just sayin'.
Comment 2 Parag Nemade 2012-07-16 12:23:47 EDT
What I will just say here is that upstream has become unresponsive and its always better to try these discussion on upstream bugzilla as we just pull upstream tarballs and build it in Fedora.
Comment 3 pscottdv 2012-10-11 12:23:09 EDT
I filed the following bug with bugzilla.gnome.org:

https://bugzilla.gnome.org/show_bug.cgi?id=680556

And user anish appears to have provided a patch for the ~ and ^ characters.  Perhaps Fedora could see about integrating it into their rpm?
Comment 4 Daiki Ueno 2013-03-27 06:19:46 EDT
It should be fixed in caribou 0.4.8 (available in rawhide and f19).

Note You need to log in before you can comment on or make changes to this bug.