Bug 829024 - [abrt] setroubleshoot-server-3.1.11-1.fc17: __init__.py:49:seinfo:RuntimeError: No default policy found.
[abrt] setroubleshoot-server-3.1.11-1.fc17: __init__.py:49:seinfo:RuntimeErro...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Daniel Walsh
Fedora Extras Quality Assurance
abrt_hash:6fe87bbb0e03f62de086f9a6895...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 15:33 EDT by totophe56
Modified: 2013-08-01 14:42 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-08-01 14:42:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description totophe56 2012-06-05 15:33:02 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
cmdline:        /usr/bin/python -Es /usr/bin/sealert -b
comment:        tentative lancement amsn
executable:     /usr/bin/sealert
kernel:         3.3.7-1.fc17.x86_64
time:           mar. 05 juin 2012 10:14:01 CEST
uid:            1000
username:       chris

backtrace:
:__init__.py:49:seinfo:RuntimeError: No default policy found.
:
:Traceback (most recent call last):
:  File "/usr/bin/sealert", line 50, in <module>
:    from setroubleshoot.util import get_identity, load_plugins
:  File "/usr/lib64/python2.7/site-packages/setroubleshoot/util.py", line 283, in <module>
:    file_types =  setools.seinfo(setools.ATTRIBUTE,"file_type")[0]["types"]
:  File "/usr/lib64/python2.7/site-packages/setools/__init__.py", line 49, in seinfo
:    dict_list = _seinfo.seinfo(setype, name)
:RuntimeError: No default policy found.
:
:Local variables in innermost frame:
:setype: 1
:name: 'file_type'

smolt_data:
:
:
:Général
:=================================
:UUID: 93613d74-660a-498c-b198-b4859eccfb87
:SE: Fedora release 17 (Beefy Miracle)
:Niveau d'exécution par défaut: Unknown
:Langue: fr_FR.UTF-8
:Plateforme: x86_64
:BogoMIPS: 4000.11
:Fabricant du processeurs: AuthenticAMD
:Modèle de processeur: AMD Athlon(tm) 64 Processor 3000+
:Stepping du processeur: 2
:Famille de processeur: 15
:Modèle du processeur: 44
:Nombre de processeurs: 1
:Vitesse du processeur: 2000
:Mémoire du système: 995
:Swap du système: 2999
:Fabricant: System manufacturer
:Système: System Product Name System Version
:Type d'ordinateur: Desktop
:Noyau: 3.3.7-1.fc17.x86_64
:SELinux activé: 0
:Stratégie SELinux: targeted
:SELinux strict: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Périphériques
:=================================
:(4358:12839:4163:33005) pci, None, PCI/ISA, A7V600/K8V-X/A8V Deluxe motherboard
:(4358:12548:4163:33005) pci, ehci_hcd, USB, A7V600/K8V-X/A8V Deluxe motherboard
:(4358:12344:4163:33005) pci, uhci_hcd, USB, A7V600/K8V-X/A8V Deluxe motherboard
:(4358:12377:4163:33037) pci, snd_via82xx, MULTIMEDIA_AUDIO, Asus P5VD1-X (AD1888 codec [SoundMax])
:(4358:12344:4163:33005) pci, uhci_hcd, USB, A7V600/K8V-X/A8V Deluxe motherboard
:(4358:12344:4163:33005) pci, uhci_hcd, USB, A7V600/K8V-X/A8V Deluxe motherboard
:(4358:8834:0:0) pci, None, HOST/PCI, K8T800Pro Host Bridge
:(4358:12930:0:0) pci, None, HOST/PCI, K8T800Pro Host Bridge
:(4358:642:4163:32931) pci, agpgart-amd64, HOST/PCI, A8V Deluxe
:(4358:4738:0:0) pci, None, HOST/PCI, K8T800Pro Host Bridge
:(4358:29314:0:0) pci, None, HOST/PCI, K8T800Pro Host Bridge
:(4358:17026:0:0) pci, None, HOST/PCI, K8T800Pro Host Bridge
:(4358:45448:0:0) pci, None, PCI/PCI, VT8237 PCI bridge [K8T800/K8T890 South]
:(4130:4353:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] Address Map
:(4130:4352:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] HyperTransport Technology Configuration
:(4130:4355:0:0) pci, k8temp, HOST/PCI, K8 [Athlon64/Opteron] Miscellaneous Control
:(4130:4354:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] DRAM Controller
:(4358:12344:4163:33005) pci, uhci_hcd, USB, A7V600/K8V-X/A8V Deluxe motherboard
:(4358:12392:0:0) pci, None, SIMPLE, AC'97 Modem Controller
:(4318:788:5218:37638) pci, None, VIDEO, NV31 [GeForce FX 5600XT]
:(4358:12389:4163:33005) pci, via-rhine, ETHERNET, A7V600-X Motherboard
:(4358:12617:4163:33005) pci, sata_via, RAID, A7V600/K8V Deluxe/K8V-X/A8V Deluxe motherboard
:(4358:1393:4163:33005) pci, pata_via, STORAGE, A7V600/K8V-X/A8V Deluxe motherboard
:
:
:Informations sur le système de fichiers
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda5 / ext4 4096 4096 7661494 6405171 6021171 1921360 1738252 1738252
:/dev/sda3 WITHHELD ext4 4096 4096 12774619 12552927 11912927 3203072 3203061 3203061
:/dev/sda2 /boot ext4 1024 1024 508745 447487 421887 128016 127633 127633
:/dev/sda6 /home ext4 4096 4096 7661494 7484486 7100486 1921360 1920093 1920093
:/dev/mapper/vg_serveurweb-lv01 WITHHELD ext4 4096 4096 17893905 17595145 16698941 4481024 4480369 4480369
:/dev/mapper/vg_serveurweb-lv02 WITHHELD ext4 4096 4096 23874916 23489079 22293457 5980160 5980149 5980149
:/dev/mapper/vg_serveurweb-lv00 WITHHELD ext4 4096 4096 51137456 50343835 47783835 12804096 12804080 12804080
:
Comment 1 Daniel Walsh 2012-06-07 12:33:27 EDT
Did you run this command on a machine without the selinux-policy-targeted package installed?
Comment 2 totophe56 2012-06-08 04:19:36 EDT
no the linux policy was targeted

i mised install tklib

the trouble is solved

thanks
Comment 3 Daniel Walsh 2012-06-08 07:05:40 EDT
Will be fixed to not crash if selinux-policy is not installed in  setroubleshoot-3.1.12.
Comment 4 Alexey Shtykov 2012-06-13 15:32:27 EDT
Unable to authorise any admin action from GUI after I have to disable SELinux that denies me to do these things

Package: setroubleshoot-server-3.1.9-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 5 Alexey Shtykov 2012-06-13 15:40:28 EDT
0. All recomendations from SELinux troubleshoot have being applied
1. SELinux prevents me to mount local drives
2. SELinux policy have being upgraded to 128
  yum update --enablerepo=updates-testing selinux-policy-3.10.0-128.fc17
3. Reboot
4. SELinux continue to protect me from my local filesystems
5. SELinux disabled through /etc/selinux/conf
6. Reboot
7. SELinux continue to protect me from my local filesystems
8. Unable to see new solution from SELinux troubleshoot (see Comment #4)
Comment 6 Daniel Walsh 2012-06-13 17:26:04 EDT
If SELinux is disabled it is not preventing you from doing anything. Why are you adding to this bugzilla.  If you have a support issue please ask on the mailing list or irc.  

You could boot the kernel with selinux=0 option to make sure it is disabled.
Comment 7 Alexey Shtykov 2012-06-14 04:24:32 EDT
I'm sorry. I just followed the standard procedure. I will try to avoid this action in the future.
I have used RedHat since 1995 and before SELinux become an integral part of the system I have not experienced problems when changing release. I would really like that it was disappeared, but unfortunatelly, it's not possible.
Comment 8 Daniel Walsh 2012-06-14 15:07:16 EDT
I am not sure what standard procedure you are talking about.  If you want to disable SELinux on a fresh install you can do this in a kickstart.  You can add selinux=0 to the grub entry of the kernel or disable selinux in /etc/selinux/config.

If you want SELinux turned off you probably do not even want setroubleshoot installed

yum remove setroubleshoot
Comment 9 Alexey Shtykov 2012-06-15 08:28:48 EDT
Standard procedure is to press a "Report bug" button.
Thanks for Your time. Now I'm sure - the best way to avoid problems with SELinux is to turn SELinux off after an upgrade. I will do it today. But,for now, I'm not sure that problem is inside SELinux - it also can be inside GNOME/KDE or security wrapper using them to confirm rights for mounting filesystems or confirming keys for packages during system update. Fresh install does not have this problem, but it completelly destroys my data.
As I understand SELinux Troubeshooter just indicate problems that have created lately. So removing SELinux Troubeshooter - is to break the red light instead of to solve the problem, which leads to its blinking.
Comment 10 Daniel Walsh 2012-06-15 11:55:13 EDT
Alexey if you want to talk about what SELinux is reporting, then fine I will help you fix them,  If you come in and say SELinux sucks, I turn it off, then I say fine.  Once you turn SELinux off, remove these packages and if you have other problems go to fedora-list for help, or report bugs on other parts of the system.  SELinux Troubleshooter is not going to report problems on an SELinux disabled system.
Comment 11 GeoffLeach 2012-06-29 15:54:04 EDT
selinux is disabled. settings same as f16

Package: setroubleshoot-server-3.1.11-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 12 GeoffLeach 2012-06-29 16:09:01 EDT
I have removed the setroubleshoot package. I'll report back on the results. BTW, I'm not trying to debug selinux problems; just being a good user (IMHO) by reporting problems that are reported by abrt.
Comment 13 GeoffLeach 2012-06-30 15:47:45 EDT
Removal of setroubleshoot did not change the problem. I won't report duplicates (one per day) unless requested.
Comment 14 Daniel Walsh 2012-07-18 17:02:09 EDT
Just catching up on this, but could you report what you are still seeing?

yum remove setroubleshoot-server
Comment 15 GeoffLeach 2012-07-19 13:34:38 EDT
Hmmm ... didn't I do this already? Oh well ....

#yum remove setroubleshoot-server

problem solved. Guess I didn't run that before. Thanks.
Comment 16 Jan Vlug 2012-07-22 08:54:24 EDT
Tried to start SELinux Troubleshoot.

Package: setroubleshoot-server-3.1.12-1.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 17 GeoffLeach 2012-07-22 09:16:54 EDT
Did you try "yum remove setroubleshoot-server"?
Comment 18 Jan Vlug 2012-07-22 09:39:14 EDT
I had no selinux policy installed.
yum install selinux-policy-targeted
solved the issue.
Comment 19 Fedora End Of Life 2013-07-04 03:00:06 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 20 Fedora End Of Life 2013-08-01 14:42:12 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.