Bug 829032 - livecd-creator fails with traceback.
livecd-creator fails with traceback.
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: livecd-tools (Show other bugs)
rawhide
All Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 15:50 EDT by Raphael Groner
Modified: 2012-09-25 16:08 EDT (History)
15 users (show)

See Also:
Fixed In Version: livecd-tools-18.7-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-08-24 23:03:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
root.log (3.91 KB, text/plain)
2012-06-05 15:50 EDT, Raphael Groner
no flags Details

  None (edit)
Description Raphael Groner 2012-06-05 15:50:51 EDT
Created attachment 589622 [details]
root.log

Description of problem:
Build of F17 Live CD fails due to an issue with Plymouth. See attached root.log

Version-Release number of selected component (if applicable):
F18/Rawhide

How reproducible:
yes


Steps to Reproduce:
1. http://koji.fedoraproject.org/koji/taskinfo?taskID=4129496
3.
  
Actual results:
Fails

Expected results:
A working configuration for plymouth or the like.

Additional info:
Maybe install caribou as suggested at:
http://forums.fedoraforum.org/showthread.php?s=8fcfc3d888aff30874eb1be39febf741&p=1557764#post1557764
See also:
https://bugzilla.redhat.com/show_bug.cgi?id=642617
Comment 1 Christoph Wickert 2012-06-06 06:09:54 EDT
(In reply to comment #0)
> Build of F17 Live CD fails due to an issue with Plymouth.

1. You are building an F18 livecd
2. The problem is caused by the %postrans script of the kernel package.
Comment 2 Raphael Groner 2012-06-07 10:47:29 EDT
(In reply to comment #1)
> (In reply to comment #0)
> > Build of F17 Live CD fails due to an issue with Plymouth.
> 
> 1. You are building an F18 livecd
Right. Sorry for any confusion.

> 2. The problem is caused by the %postrans script of the kernel package.
Do you have a patch? Maybe someone should reassign then to Component kernel.

This bug seems to break all live medias. I guess it should get some higher alertness, shouldn't it?
Comment 3 Kevin Fenzi 2012-06-07 11:22:20 EDT
It's not clear to me if this is a kernel issue, or a livecd-creator one.
Comment 4 Ray Strode [halfline] 2012-06-12 11:53:21 EDT
latest log actually shows two issues:

http://koji.fedoraproject.org/koji/getfile?taskID=4153282&name=root.log

1) livecd is creating a dracut.conf that includes ext4 module when ext4 is a built in.  Harald said he'll fix dracut to work around dracut.conf files that do that.

2) livecd-creator is not handling some symlink (or so) right with copyfile and it's making it blow up.

moving to livecd-creator for 2.

I fixed the problem mentioned in the bug summary upstream here:

http://cgit.freedesktop.org/plymouth/commit/?id=d80a23cb59aee76c430b738c33480d67d940d939

It's a dep ordering issue that keeps cropping up, so I've just removed the dep.
Comment 5 Brian Lane 2012-06-12 15:18:44 EDT
That error would seem to indicate that /etc/localtime is a symlink to the zoneinfo file instead of a copy. I wonder why?

Changing the copyfile to copy2 works fine.

Also, I'd like to encourage people to give livemedia-creator a try for creating live media for F17 and later. You can find it in the lorax package.
Comment 6 Kevin Fenzi 2012-06-12 16:06:56 EDT
This changed in glibc recently: 

https://bugzilla.redhat.com/show_bug.cgi?id=822200
Comment 7 Adam Williamson 2012-07-30 20:07:59 EDT
Regarding "livecd is creating a dracut.conf that includes ext4 module when ext4 is a built in.  Harald said he'll fix dracut to work around dracut.conf files that do that." - is it possible the identical issue exists for ext3 but wasn't fixed? I just tried to generate a live image of Rawhide with livecd-creator and I'm looking at:

E: No '/dev/log' or 'logger' included for syslog logging
F: Failed to install ext3
F: installkernel failed in module kernel-modules
mkinitrd failed
warning: %posttrans(kernel-3.6.0-0.rc0.git2.1.fc18.x86_64) scriptlet failed, exit status 1
Comment 8 Fedora Update System 2012-07-31 17:07:50 EDT
livecd-tools-17.12-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.12-1.fc17
Comment 9 Fedora Update System 2012-08-01 18:28:23 EDT
Package livecd-tools-17.12-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing livecd-tools-17.12-1.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11389/livecd-tools-17.12-1.fc17
then log in and leave karma (feedback).
Comment 10 Fedora Update System 2012-08-02 14:57:18 EDT
livecd-tools-17.13-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.13-1.fc17
Comment 11 Brian Lane 2012-08-02 16:17:51 EDT
This should fix things (18.7 and 17.13) adamw who has reproduced the bug tested it and confirmed that it works. For some reason I don't see the problem on my setup using F16.
Comment 12 Fedora Update System 2012-08-06 15:03:38 EDT
livecd-tools-17.14-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/livecd-tools-17.14-1.fc17
Comment 13 Fedora Update System 2012-08-24 23:03:22 EDT
livecd-tools-17.14-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 14 jmccann 2012-09-25 16:08:06 EDT
Any chance we can update the epel 6 version too?

Note You need to log in before you can comment on or make changes to this bug.