Bug 829049 - SELinux is preventing /usr/lib64/nspluginwrapper/npviewer.bin from 'execute_no_trans' accesses on the file /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/bin/java.
SELinux is preventing /usr/lib64/nspluginwrapper/npviewer.bin from 'execute_n...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:0d990abdd282bb84917c88a3de9...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 16:31 EDT by Gabriel
Modified: 2012-06-22 06:00 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-22 06:00:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gabriel 2012-06-05 16:31:51 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Tue 05 Jun 2012 01:31:33 PM PDT

description:
:SELinux is preventing /usr/lib64/nspluginwrapper/npviewer.bin from 'execute_no_trans' accesses on the file /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/bin/java.
:
:*****  Plugin leaks (86.2 confidence) suggests  ******************************
:
:If you want to ignore npviewer.bin trying to execute_no_trans access the java file, because you believe it should not need this access.
:Then you should report this as a bug.  
:You can generate a local policy module to dontaudit this access.
:Do
:# grep /usr/lib64/nspluginwrapper/npviewer.bin /var/log/audit/audit.log | audit2allow -D -M mypol
:# semodule -i mypol.pp
:
:*****  Plugin catchall (14.7 confidence) suggests  ***************************
:
:If you believe that npviewer.bin should be allowed execute_no_trans access on the java file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep npviewer.bin /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c
:                              0.c1023
:Target Context                system_u:object_r:lib_t:s0
:Target Objects                /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre
:                              /bin/java [ file ]
:Source                        npviewer.bin
:Source Path                   /usr/lib64/nspluginwrapper/npviewer.bin
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           nspluginwrapper-1.4.4-9.fc17.x86_64
:Target RPM Packages           java-1.7.0-openjdk-1.7.0.3-2.1.fc17.6.x86_64
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Enforcing
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.x86_64 #1
:                              SMP Mon May 21 22:32:19 UTC 2012 x86_64 x86_64
:Alert Count                   2
:First Seen                    Tue 05 Jun 2012 11:55:34 AM PDT
:Last Seen                     Tue 05 Jun 2012 11:59:45 AM PDT
:Local ID                      e829e348-d2a6-4dd4-a93c-bc4995762f0d
:
:Raw Audit Messages
:type=AVC msg=audit(1338922785.983:101): avc:  denied  { execute_no_trans } for  pid=3904 comm="npviewer.bin" path="/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/bin/java" dev="sda2" ino=932574 scontext=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 tcontext=system_u:object_r:lib_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1338922785.983:101): arch=x86_64 syscall=execve success=no exit=EACCES a0=9c0260 a1=7fffc0e773a0 a2=9c0ab0 a3=7fffc0e76e90 items=0 ppid=1 pid=3904 auid=1000 uid=1000 gid=1000 euid=1000 suid=1000 fsuid=1000 egid=1000 sgid=1000 fsgid=1000 tty=(none) ses=2 comm=npviewer.bin exe=/usr/lib64/nspluginwrapper/npviewer.bin subj=unconfined_u:unconfined_r:mozilla_plugin_t:s0-s0:c0.c1023 key=(null)
:
:Hash: npviewer.bin,mozilla_plugin_t,lib_t,file,execute_no_trans
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Miroslav Grepl 2012-06-22 06:00:24 EDT
This is mislabeled file.

Execute

# restorecon -R -v /usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/bin/java

Note You need to log in before you can comment on or make changes to this bug.