Bug 829102 - qemu-supplied SystemTap tapsets cause errors
qemu-supplied SystemTap tapsets cause errors
Status: CLOSED DUPLICATE of bug 831763
Product: Fedora
Classification: Fedora
Component: qemu (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Fedora Virtualization Maintainers
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-05 21:36 EDT by Nicholas Miell
Modified: 2013-01-09 07:03 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-10 07:23:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicholas Miell 2012-06-05 21:36:48 EDT
parse error: expected statement
	saw: keyword at /usr/share/systemtap/tapset/qemu-kvm.stp:1139:3
     source:   in = $arg3;
               ^
parse error: expected literal string or number
	saw: operator '=' at /usr/share/systemtap/tapset/qemu-kvm.stp:2078:8
     source:   next = $arg1;
                    ^
2 parse errors.
parse error: expected statement
	saw: keyword at /usr/share/systemtap/tapset/qemu-system-i386.stp:1139:3
     source:   in = $arg3;
               ^
parse error: expected literal string or number
	saw: operator '=' at /usr/share/systemtap/tapset/qemu-system-i386.stp:2078:8
     source:   next = $arg1;
                    ^
2 parse errors.
parse error: expected statement
	saw: keyword at /usr/share/systemtap/tapset/qemu-system-x86_64.stp:1139:3
     source:   in = $arg3;
               ^
parse error: expected literal string or number
	saw: operator '=' at /usr/share/systemtap/tapset/qemu-system-x86_64.stp:2078:8
     source:   next = $arg1;
                    ^
2 parse errors.

"in" and "next" are both SystemTap keywords.
Comment 1 Paolo Bonzini 2012-06-11 03:43:08 EDT
This has been fixed upstream already for "next", but "in" still remains and will still cause syntax errors.

usb_host_req_data(int bus, int addr, void *p, int in, int ep, int size) "dev %d:%d, packet %p, in %d, ep %d, size %d"

Gerd, can you look at this?
Comment 2 Cole Robinson 2012-07-10 07:23:40 EDT

*** This bug has been marked as a duplicate of bug 831763 ***

Note You need to log in before you can comment on or make changes to this bug.