Bug 829122 - Crash of KDE services on startup 4.8.3
Crash of KDE services on startup 4.8.3
Status: CLOSED DUPLICATE of bug 751891
Product: Fedora
Classification: Fedora
Component: kde-runtime (Show other bugs)
16
Unspecified Unspecified
unspecified Severity urgent
: ---
: ---
Assigned To: Ngo Than
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 00:17 EDT by Christian Groove
Modified: 2012-06-06 13:07 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 13:07:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Comment (178.71 KB, text/plain)
2012-06-06 00:17 EDT, Christian Groove
no flags Details

  None (edit)
Description Christian Groove 2012-06-06 00:17:23 EDT
Created attachment 915460 [details]
Comment

(This comment was longer than 65,535 characters and has been moved to an attachment by Red Hat Bugzilla).
Comment 1 Christian Groove 2012-06-06 09:27:02 EDT
Dear friends,

this is not a NVIDIA problem as states in the
KDE-bugzilla. When i recognized a change on 
kde-libs.

My previously locate NVIDIA problem has already
been fixed before.

Christian
Comment 2 Rex Dieter 2012-06-06 09:39:46 EDT
#0  elf_machine_rela_relative (reloc_addr_arg=0x63b44f95, l_addr=1648185344, reloc=<optimized out>) at ../sysdeps/i386/dl-machine.h:644

This is the same crash/backtrace, and

0xb0689f80  0xb06e699c  Yes (*)     /usr/lib/nvidia/libGL.so.1
0x4e541df0  0x4e5434b3  Yes (*)     /usr/lib/nvidia/tls/libnvidia-tls.so.295.53
0xaee5bb00  0xaffe0b10  Yes (*)     /usr/lib/nvidia/libnvidia-glcore.so.295.53

So, yeah, it really does look like the same nvidia/glibc issue.
Comment 3 Rex Dieter 2012-06-06 09:50:01 EDT

*** This bug has been marked as a duplicate of bug 751891 ***
Comment 4 Christian Groove 2012-06-06 10:11:51 EDT
Sorry friend,

the crash/backtrace only shows, that my application has
the same dll-mapping compared to another problem.
I believe, that it does not show, that the dll caused
the same problem.

Besides, kded is a service an not a GUI application.
I think it maps kde libraries but i do not believe,
that it will use 3D operations.

And ...the KDE problems occures, when 
fedora shipped a update on KDE not(!) nvidia!

Last not least, the recent nvidia version > 290
fixed some problems with KDE, i am using 295!

For me, it looks like a kde problem!
Comment 5 Rex Dieter 2012-06-06 10:15:34 EDT
You're welcome to your own opinion.

The (hopefully uncontroversial) fact is that it's lower than kde, it's an incompatiblity between glibc and attempts to dlopen nvidia's libGL libs.

You have some options to mitigate and minimize such crashes:
* don't use nvidia blob
* manually re-run glibc prelinking when upgrading kdelibs (sometimes helps)
* disable glibc prelinking (sometimes helps)
Comment 6 Kevin Kofler 2012-06-06 13:07:54 EDT
> the crash/backtrace only shows, that my application has
> the same dll-mapping compared to another problem.

No, it also shows that it crashes at the exact same place, in the exact same glibc function.

> I believe, that it does not show, that the dll caused
> the same problem.

See above, the backtrace is exactly the same, not just the library map.

> Besides, kded is a service an not a GUI application.
> I think it maps kde libraries but i do not believe,
> that it will use 3D operations.

It doesn't matter whether it actually USES them, it only matters that it LOADS them, and it definitely does, as your library map shows.

In fact, as far as I can tell, the condition which triggers the crash is that the program dlopens anything directly or indirectly linked to libGL (or just libGL itself). And then it only happens under certain conditions related to the addresses assigned by prelink (my guess: only when the prelinked addresses happen to overlap and so the library needs to be relocated at runtime).

In kded4, there are several cases where this can happen:
* kded4 itself has modules (i.e. dlopened plugins), which end up indirectly linked to libGL.
* Some kded4 modules are linked to Phonon which has dlopened backends linked to multimedia frameworks such as GStreamer, which of course also link libGL at some place.

> And ...the KDE problems occures, when 
> fedora shipped a update on KDE not(!) nvidia!

As I explained, the crash only occurs when the addresses assigned by prelink happen to trigger it. ANY update to ANY library, or even just the routine reprelinking cronjob, can trigger the crash. It does not imply that the bug is not in the nvidia driver.

> Last not least, the recent nvidia version > 290
> fixed some problems with KDE, i am using 295!

Both NVidia and glibc upstream claimed they fixed the problem. (Both the nvidia driver and glibc were updated with a supposed fix.) But in fact only the direct linking case seems fixed, dlopen can still trigger the crash. Unfortunately, the main victim of the dlopen crashes is KDE, due to its heavy use of plugins, though I've also seen them triggered by plugin-based multimedia libraries.

> For me, it looks like a kde problem!

It is most definitely NOT a KDE problem. If it is a Fedora problem at all, it is in glibc. But I think it's a nvidia driver problem.

*** This bug has been marked as a duplicate of bug 751891 ***

Note You need to log in before you can comment on or make changes to this bug.