Bug 829192 - Evolution hangs after resume or after pulling the network cable
Evolution hangs after resume or after pulling the network cable
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 04:06 EDT by Herald van der Breggen
Modified: 2012-06-08 05:17 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-08 05:16:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 551788 None None None 2012-06-08 05:16:12 EDT

  None (edit)
Description Herald van der Breggen 2012-06-06 04:06:46 EDT
Description of problem:
Evolution does not handle lost connection properly, it becomes unresponsive and can only be killed with SIGKILL. This happens after a suspend/resume, but also after pulling the network cable (and putting it back).

I use evolution with imap+ over SSL and SMTP over SSL (3 accounts).

Version-Release number of selected component (if applicable):
3.4.1

How reproducible:


Steps to Reproduce:
1. start evolution with imap+ accounts over SSL 
2. suspend
3. resume
4. try to use evolution
  
Actual results:
Evolution hangs. It rare cases is even possible the cache ($HOME/.cache/evolution) is corrupt and this needs to be removed (rm -fr .cache/evolution) to make it operational again.

Expected results:
responisive


Additional info:
Comment 1 Milan Crha 2012-06-08 05:16:12 EDT
Thanks for a bug report. The network issue is already reported as [1]. Please see it for any further updates.

The ~/.cache/evolution corruption issue, I would say it's sort of expected, when you kill the application, which can be in time when it is in the middle of writing data into the cache. Luckily the cache is only a local copy of server data, thus you are not loosing any data.

[1] https://bugzilla.gnome.org/show_bug.cgi?id=551788
Comment 2 Herald van der Breggen 2012-06-08 05:17:52 EDT
Also switching from online modus to offline makes evolution hang.

In my case, all these issues are gone when switching from IMAP+ to IMAP. So it looks like evolution does not handle limitations of the imap server in a robust way (at least when IMAP+ is used, but maybe it is not limited to that).

Note You need to log in before you can comment on or make changes to this bug.