Bug 829210 - ALSA HDA - recording fails on Gigabyte H55M-UD2H motherboard
ALSA HDA - recording fails on Gigabyte H55M-UD2H motherboard
Status: CLOSED DEFERRED
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: kernel (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Jaroslav Kysela
Ken Benoit
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 04:42 EDT by Levente Farkas
Modified: 2015-10-04 14:40 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-10-04 14:40:29 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
alsa-info (36.48 KB, text/plain)
2012-07-14 16:20 EDT, Levente Farkas
no flags Details
2.6.32-220.23.1.el6.x86_64 (38.74 KB, text/plain)
2012-07-16 06:48 EDT, Levente Farkas
no flags Details
2.6.32-279.1.1.el6.x86_64 (38.92 KB, text/plain)
2012-07-16 06:48 EDT, Levente Farkas
no flags Details

  None (edit)
Description Levente Farkas 2012-06-06 04:42:08 EDT
on a Gigabyte H55M-UD2H motherboard with 
Intel Corporation 5 Series/3400 Series Chipset High Definition Audio
after updating from 6.1 to 6.2 the sound microphone input (eg in skype) become totally unusable. it's very noisy and cracking. it was working with 6.1.

i alos try the 6.3 beta kernel-2.6.32-262.el6.x86_64, but it's even worse. in the sound control currently there is line-in, microphone-1 and microphone-2. but in 6.3 there is only microphone and it's not able to detect any sound input ie. it seems the input is not working at all.
Comment 3 Jaroslav Kysela 2012-07-10 08:46:53 EDT
Please, attach output from 'alsa-info.sh --no-upload'.
Comment 4 Levente Farkas 2012-07-14 16:20:30 EDT
Created attachment 598272 [details]
alsa-info

although it's not the same machine the result is exactly the same:-) microphone is no longer working on rhel-6.3 final.
Comment 5 Levente Farkas 2012-07-16 06:48:27 EDT
Created attachment 598415 [details]
2.6.32-220.23.1.el6.x86_64
Comment 6 Levente Farkas 2012-07-16 06:48:47 EDT
Created attachment 598416 [details]
2.6.32-279.1.1.el6.x86_64
Comment 7 Levente Farkas 2012-07-16 06:52:35 EDT
here's another example. the same machine fully updated 6.3. the only difference is that i boot different kernel. while 2.6.32-220.23.1.el6.x86_64 working and 2.6.32-279.1.1.el6.x86_64 not. i attached both alsainfo. on 6.3's kernel there is no microphone1 in sound preferences/input/connector (which is working on 6.2's latest kernel) and hence there is no way to use skype on 6.3 since there is no usable input device:-(
this's a regression in 6.3.
Comment 8 Levente Farkas 2012-07-19 10:15:00 EDT
according to kernel changelog there and only sound changes:
- [sound] alsa: fix Conexant CX20561 audio mute functionality (Jaroslav Kysela) [816569]
- [sound] alsa: enable OSS emulation in rhel configuration (Jaroslav Kysela) [657291]
- [sound] alsa: add probe_mask=0x101 automatically for WinFast VP200 H (Jaroslav Kysela) [805658]
- [sound] alsa: Fix No sound with Conexant CX20585 / Recording fails (Jaroslav Kysela) [798923]
- [sound] ALSA: pcm midlevel code - add time check for (Jaroslav Kysela) [798984]
- [sound] ALSA: enable OSS emulation layer for PCM and mixer (Jaroslav Kysela) [657291]
- [sound] alsa: enable snd-cmipci driver (Jaroslav Kysela) [661316]

and this last one seems to be the best candidate:
- [sound] Update the ALSA HDA audio driver from upstream (Jaroslav Kysela) [760490]

it'd be very useful to fix it to be able to use microphone on 6.3.
Comment 9 Levente Farkas 2012-12-07 06:56:11 EST
is there any plan to fix the audio input in rhel 6.x. since it's currently only possible with the latest 6.2 kernel and almost none of our workstation is able to use new kernel because of the microphone input.
Comment 10 RHEL Product and Program Management 2012-12-14 02:42:35 EST
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 11 John Shortt 2015-10-04 14:40:29 EDT
This BZ is quite old and no update in years.  Several changes have been introduced in the 3 minor releases since, so please test against 6.7 and reopen or submit a new BZ if the problem persists.

Thanks

Note You need to log in before you can comment on or make changes to this bug.