Bug 829252 - Getting an Error/Null on 2 different rhevm-config queries
Getting an Error/Null on 2 different rhevm-config queries
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-config (Show other bugs)
3.1.0
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Yair Zaslavsky
Yaniv Kaul
infra
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 06:20 EDT by Ortal
Modified: 2016-02-10 14:16 EST (History)
9 users (show)

See Also:
Fixed In Version: si9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-04 14:58:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Infra
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ortal 2012-06-06 06:20:38 EDT
Description of problem:

Getting an Error/Null on 2 different rhevm-config queries

Version-Release number of selected component (if applicable):
RHEVM 3.1 Version rhevm-3.1.0_0001-0.scratch.el6ev.noarch

How reproducible:
Always 

Steps to Reproduce:
1. Open RHEVM shell and run: rhevm-config -a 
2. Run rhevm-config -l | grep JobCleanupRateInMinutes 
3. Run rhevm-config -a | grep FreeSpaceCriticalLowInGB
3. Open a connection to the postgresql running the command: psql engine -U postgres, and run the query:

[root@ortal-rhevm1 ~]# psql engine -U postgres
psql (8.4.9)
Type "help" for help.
engine=#
engine=# select *
engine-# from vdc_options
engine-# where option_name like 'JobCleanupRateInMinutes';
 option_id |       option_name       | option_value | version
-----------+-------------------------+--------------+---------
        97 | JobCleanupRateInMinutes | 10           | general
(1 row)


engine=# select *
from vdc_options
where option_name like 'FreeSpaceCriticalLowInGB';
 option_id | option_name | option_value | version
-----------+-------------+--------------+---------
(0 rows)

engine=#

  
Actual results:

[root@ortal-rhevm1 ~]# rhevm-config -a | grep -i error
Skipping FreeSpaceCriticalLowInGB due to an error: Error fetching FreeSpaceCriticalLowInGB value: no such entry with default version.
[root@ortal-rhevm1 ~]#                                                                                                               
[root@ortal-rhevm1 ~]#                                                                                                               
[root@ortal-rhevm1 ~]# rhevm-config -l | grep -i null
JobCleanupRateInMinutes: null (Value Type: Integer)  


Expected results:

Both params should display the relevant value as in postgres query.
Comment 1 Yair Zaslavsky 2012-07-01 10:48:50 EDT
1. JobCLeanupRateInMinutes have its description set in the config file with no ".description" suffix for the key.
2. For si7 I do not get error for FreeSpaceCriticalLowInGB, I get it for

MaxDiskSize size does not exist in vdc_optiosn anymore  - I will remove it from the config file.
Comment 2 Yair Zaslavsky 2012-07-01 11:09:01 EDT
Suggested patch - http://gerrit.ovirt.org/#/c/5809/
Comment 4 Yaniv Kaul 2012-07-11 09:48:12 EDT
How is that ON_QA, without all ACKs?
Is it for 3.1 or future? please clear the flags.
Comment 5 Yaniv Kaul 2012-08-07 07:24:21 EDT
SI13 - verified.

[root@ykaul-rhevm3 ~]# rhevm-config -a | grep -i error
[root@ykaul-rhevm3 ~]# rhevm-config -l | grep JobCleanupRateInMinutes
JobCleanupRateInMinutes: "Frequency of jobs clean-up process" (Value Type: Integer)
[root@ykaul-rhevm3 ~]# rhevm-config -a | grep FreeSpaceCriticalLowInGB
FreeSpaceCriticalLowInGB: 5 version: general
[root@ykaul-rhevm3 ~]# psql engine -U postgres
psql (8.4.12)
Type "help" for help.

engine=# select * from vdc_options where option_name like 'JobCleanupRateInMinutes';
 option_id |       option_name       | option_value | version 
-----------+-------------------------+--------------+---------
       106 | JobCleanupRateInMinutes | 10           | general
(1 row)

engine=# select *
engine-# from vdc_options
engine-# where option_name like 'FreeSpaceCriticalLowInGB';
 option_id |       option_name        | option_value | version 
-----------+--------------------------+--------------+---------
        89 | FreeSpaceCriticalLowInGB | 5            | general
(1 row)

Note You need to log in before you can comment on or make changes to this bug.