Bug 829271 - net-snmp produces error if the Executables/scripts entries in snmpd.conf is over 50.
net-snmp produces error if the Executables/scripts entries in snmpd.conf is o...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: net-snmp (Show other bugs)
6.2
All Linux
high Severity medium
: rc
: ---
Assigned To: Jan Safranek
Dalibor Pospíšil
: EasyFix, Patch, ZStream
Depends On:
Blocks: 836252
  Show dependency treegraph
 
Reported: 2012-06-06 07:05 EDT by tvizirov
Modified: 2013-02-21 05:27 EST (History)
8 users (show)

See Also:
Fixed In Version: net-snmp-5.5-44.el6
Doc Type: Bug Fix
Doc Text:
Prior to this update, there was a limit of 50 'exec' entries in /etc/snmp/snmpd.conf. With more than 50 such entries in the configuration file, snmpd reported "Error: No further UCD-compatible entries" in the system log. In this update this fixed limit is removed and there can be any number of 'exec' entries in the snmpd configuration file.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:27:13 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
proposed patch (412 bytes, patch)
2012-06-06 07:28 EDT, mahaveer darade
no flags Details | Diff
new patch, with dynamic reallocation when needed (1.70 KB, patch)
2012-06-27 09:58 EDT, Jan Safranek
no flags Details | Diff

  None (edit)
Description tvizirov 2012-06-06 07:05:28 EDT
Description of problem:

  If there are more than 50 Executables/scripts entries in snmpd.conf, net-snmp-5.5-37.el6_2.1.x86_64 produces the following error in /var/log/messages and ignores the entries above 50:

"/etc/snmp/snmpd.conf: line XX: Error: No further UCD-compatible entries"



Version-Release number of selected component (if applicable):

  net-snmp-5.5-37.el6_2.1.x86_64

How reproducible:

  Every time. 

Steps to Reproduce:

  1. enter more than 50 "exec" entries in the snmpd.conf file
  2. restart snmp


Actual results:

  Error message is logged in /var/log/messages

"/etc/snmp/snmpd.conf: line XX: Error: No further UCD-compatible entries"


Expected results:

  No errors. 


Additional info:

The error is produced because there is a limit in snmpd ( in extend.c ) of max 50 exec entries. 
We have built a test package which fixes the issue. We increased the value of:

  Max_compatability_entries int = 50;

Is it possible to increase the number in the next release?
Comment 2 mahaveer darade 2012-06-06 07:28:03 EDT
Created attachment 589840 [details]
proposed patch
Comment 10 Jan Safranek 2012-06-27 09:58:27 EDT
Created attachment 594782 [details]
new patch, with dynamic reallocation when needed
Comment 12 Jan Safranek 2012-06-29 09:33:11 EDT
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Prior to this update, there was a limit of 50 'exec' entries in /etc/snmp/snmpd.conf. With more than 50 such entries in the configuration file, snmpd reported "Error: No further UCD-compatible entries" in the system log. In this update this fixed limit is removed and there can be any number of 'exec' entries in the snmpd configuration file.
Comment 18 errata-xmlrpc 2013-02-21 05:27:13 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0421.html

Note You need to log in before you can comment on or make changes to this bug.