Bug 829311 - 2.22.52.0.4-1.fc18 causing issues on ARM
2.22.52.0.4-1.fc18 causing issues on ARM
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: binutils (Show other bugs)
rawhide
Unspecified Unspecified
high Severity high
: ---
: ---
Assigned To: Nick Clifton
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2012-06-06 08:50 EDT by Peter Robinson
Modified: 2012-07-16 06:57 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-16 06:57:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Peter Robinson 2012-06-06 08:50:48 EDT
binutils-2.22.52.0.3-1.fc18 is causing issues on ARM, QT is one that's visible

Example  QT build:
http://arm.koji.fedoraproject.org/taskinfo?taskID=885382

Errors.
/usr/bin/ld: BFD version 2.22.52.0.3-1.fc18 20120507 assertion fail elf32-arm.c:12264
/usr/bin/ld: BFD version 2.22.52.0.3-1.fc18 20120507 assertion fail elf32-arm.c:12264
/usr/bin/ld: BFD version 2.22.52.0.3-1.fc18 20120507 assertion fail elf32-arm.c:12264
/usr/bin/ld: BFD version 2.22.52.0.3-1.fc18 20120507 assertion fail elf32-arm.c:12264
/usr/bin/ld: BFD version 2.22.52.0.3-1.fc18 20120507 assertion fail elf32-arm.c:12264
/usr/bin/ld: BFD version 2.22.52.0.3-1.fc18 20120507 assertion fail elf32-arm.c:12264
/usr/bin/ld: BFD version 2.22.52.0.3-1.fc18 20120507 assertion fail elf32-arm.c:12264
/usr/bin/ld: BFD version 2.22.52.0.3-1.fc18 20120507 assertion fail elf32-arm.c:12264
Comment 1 Peter Robinson 2012-06-06 09:12:03 EDT
It seems QT built fine with binutils-2.22.52.0.2-1.fc18. Will untag the new version and see if the problem goes away
Comment 2 Peter Robinson 2012-06-08 05:41:41 EDT
Confirmed that QT builds fine with binutils-2.22.52.0.2-1.fc18.

I've seen that there's a new .4 release in rawhide so will retest with that again shortly.
Comment 3 Peter Robinson 2012-06-22 11:42:22 EDT
The problem still exists with the new binutils-2.22.52.0.4-1.fc18
Comment 4 Peter Robinson 2012-06-26 06:29:05 EDT
Ping, it's affecting xulrunner as well.

http://arm.koji.fedoraproject.org/koji/taskinfo?taskID=929325
Comment 5 Nick Clifton 2012-06-26 09:57:17 EDT
Hi Peter,

  Would it be possible to put together a self-contained testcase to reproduce this problem ?  Ideally a set of object files and a linker command line would be best.

  The problem appears to be related to the FSF binutils PR 13990:

http://sourceware.org/bugzilla/show_bug.cgi?id=13990

  The patch for that PR however is in the f18 sources, so I suspect that the patch was only a partial fix for a larger problem.

Cheers
  Nick
Comment 6 Peter Robinson 2012-06-26 10:11:07 EDT
>   Would it be possible to put together a self-contained testcase to
> reproduce this problem ?  Ideally a set of object files and a linker command
> line would be best.

I'm sure it would be but I have no idea how to go about that

>   The problem appears to be related to the FSF binutils PR 13990:
> 
> http://sourceware.org/bugzilla/show_bug.cgi?id=13990

Yes, looks very similar.

>   The patch for that PR however is in the f18 sources, so I suspect that the
> patch was only a partial fix for a larger problem.

OK. This is very much out of my depth, what would have changed to affect this between 2.22.52.0.2 and 2.22.52.0.3 given that .3 is when the issues appeared? Can that change be reverted?
Comment 7 Nick Clifton 2012-06-29 10:04:19 EDT
Hi Peter,

  Please could you try out binutils-2.22.52.0.4-4.fc18 in rawhide.  This *might* fix the problem.

Cheers
  Nick
Comment 8 Peter Robinson 2012-07-03 04:33:54 EDT
Hi Nick,

>   Please could you try out binutils-2.22.52.0.4-4.fc18 in rawhide.  This
> *might* fix the problem.

It looks like it has, xulrunner has built, QT hasn't yet failed, will update when QT completes. thanks
Comment 9 Peter Robinson 2012-07-16 06:57:22 EDT
Confirmed binutils-2.22.52.0.4-4.fc18 fixes the build issues

Note You need to log in before you can comment on or make changes to this bug.