Bug 829312 - VDSM: vdsm RPM should have dependency on vdsm-gluster RPM
VDSM: vdsm RPM should have dependency on vdsm-gluster RPM
Status: CLOSED NOTABUG
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Shireesh
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 08:54 EDT by Daniel Paikov
Modified: 2013-07-04 03:57 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-10 02:12:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Paikov 2012-06-06 08:54:53 EDT
vdsm RPM should have dependency on vdsm-gluster RPM. Otherwise "service vdsmd start" fails.
Comment 2 Bala.FA 2012-06-08 01:43:16 EDT
In theory it should not fail to start without vdsm-gluster rpm.  Could you send me vdsm.log on failure?
Comment 3 Bala.FA 2012-06-08 06:27:22 EDT
You can also give me 'service vdsmd start' output on failure.
Comment 4 Bala.FA 2012-06-08 06:43:46 EDT
vdsm without gluster rpm works fine for me.  Please add 'rpm -qa | grep vdsm' output here.

Well.  If I add vdsm-gluster dep to vdsm, it will be cyclic dependency.  Either we remove vdsm dependency to vdsm-gluster and add vdsm-gluster dependency to vdsm or leave to the current behaviour ie vdsm-gluster depends on vdsm and you should explicitly install vdsm-gluster by hand.
Comment 5 Shireesh 2012-06-08 08:51:55 EDT
I think it is ok for user to install vdsm-gluster manually in case of upstream. In downstream, all required packages (including vdsm-gluster) will be installed by default in the RHS2.0 servers, so we will not have any issues. (This is still in the works, and should be available very soon in RHS2.0)

Daniel, if you are not able to start vdsmd because of the dependency issue, please provide details requested by Bala.
Comment 6 Daniel Paikov 2012-06-10 02:12:23 EDT
I think I had a different problem that prevented me from running vdsmd. Closing the bug.

Note You need to log in before you can comment on or make changes to this bug.