Bug 829319 - reading pin from file can make all TLS connections hang
reading pin from file can make all TLS connections hang
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: openldap (Show other bugs)
6.3
Unspecified Unspecified
high Severity high
: rc
: ---
Assigned To: Jan Vcelak
David Spurek
:
Depends On: 829317
Blocks: 836160
  Show dependency treegraph
 
Reported: 2012-06-06 09:03 EDT by Jan Vcelak
Modified: 2015-03-02 00:26 EST (History)
6 users (show)

See Also:
Fixed In Version: openldap-2.4.23-29.el6
Doc Type: Bug Fix
Doc Text:
Cause: Password protected Mozilla NSS certificate database used to store server/client certificate. Password file provided to open the database without user interaction. Consequence: Possible reading of unallocated memory and considering its content to be a password, causing the connection to hang. Fix: Patch applied to correctly allocate the memory for the password file. Result: The content of password file is read correctly, connection will not hang.
Story Points: ---
Clone Of: 829317
Environment:
Last Closed: 2013-02-21 04:46:00 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Vcelak 2012-06-06 09:03:56 EDT
+++ This bug was initially created as a clone of Bug #829317 +++

Description of problem:

The buffer allocated for reading password (pin) file has to be initialized with
zeros, or we need to append zero at the end of the file. Otherwise we might read
initialized memory and consider it to be a password. In this situation, all
incoming TLS connections can hang.

Reported upstream:
http://www.openldap.org/its/index.cgi?findid=7291

Patch submitted upstream:
ftp://ftp.openldap.org/incoming/jvcelak-20120606-moznss-read-pin-from-file-infinite-loop.patch

Version-Release number of selected component (if applicable):
any


How reproducible:
Not always, depends on what malloc() gives us when allocating the buffer for the password.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 3 Jan Vcelak 2012-09-25 12:10:28 EDT
Resolved in: openldap-2.4.23-29.el6
Comment 8 errata-xmlrpc 2013-02-21 04:46:00 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0364.html

Note You need to log in before you can comment on or make changes to this bug.