Bug 829352 - [abrt] subversion-1.7.4-6.fc17: __GI_raise: Process /usr/bin/svn was killed by signal 6 (SIGABRT)
[abrt] subversion-1.7.4-6.fc17: __GI_raise: Process /usr/bin/svn was killed b...
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: subversion (Show other bugs)
17
i686 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joe Orton
Fedora Extras Quality Assurance
abrt_hash:61f7db82948239bab164a17ff5d...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 10:27 EDT by Gabriele Svelto
Modified: 2013-07-31 21:26 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-07-31 21:26:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: dso_list (4.94 KB, text/plain)
2012-06-06 10:27 EDT, Gabriele Svelto
no flags Details
File: maps (13.88 KB, text/plain)
2012-06-06 10:27 EDT, Gabriele Svelto
no flags Details
File: backtrace (14.49 KB, text/plain)
2012-06-06 10:27 EDT, Gabriele Svelto
no flags Details

  None (edit)
Description Gabriele Svelto 2012-06-06 10:27:38 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        svn upgrade
crash_function: __GI_raise
executable:     /usr/bin/svn
kernel:         3.3.7-1.fc17.i686
pid:            13559
pwd:            /home/crystall/projects/flowtraders/piranha/Connectivity/branches/pof
time:           Wed 06 Jun 2012 04:11:41 PM CEST
uid:            1000
username:       crystall

backtrace:      Text file, 14836 bytes
dso_list:       Text file, 5061 bytes
maps:           Text file, 14215 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/crystall/65

comment:
:1. Checkout a repository with subversion-1.6.x
:2. Take a subdirectory from the checkout and move it outside of the root of the checkout
:3. Enter the moved directory and run 'svn ugprade' with subversion-1.7.x
:4. Subversion will fail as it cannot find the parent directory, the following error message is printed out before the core dump
:
:svn: E235000: In file 'subversion/libsvn_wc/entries.c' line 1666: assertion failed (parent_node || entry->schedule == svn_wc_schedule_normal)

core_backtrace:
:a7d01277a5a79897325c2740f58261aaa18d2907 0x416 __kernel_vsyscall linux-gate.so.1 -
:f13e5fa699a7129ee3080ddeb31558ef7578cddb 0x2e95f raise libc.so.6 -
:f13e5fa699a7129ee3080ddeb31558ef7578cddb 0x302b3 abort libc.so.6 -
:7258fe20e1dd7632c7df62804d62a93b5091b4c0 0x2161f svn_error_abort_on_malfunction libsvn_subr-1.so.0 -
:7258fe20e1dd7632c7df62804d62a93b5091b4c0 0x21675 svn_error__malfunction libsvn_subr-1.so.0 -
:0ce1d6551e6e844dbdbc334916d33387981580d6 0x28ab7 - libsvn_wc-1.so.0 -
:0ce1d6551e6e844dbdbc334916d33387981580d6 0x2c2d4 svn_wc__write_upgraded_entries libsvn_wc-1.so.0 -
:0ce1d6551e6e844dbdbc334916d33387981580d6 0x513ec - libsvn_wc-1.so.0 -
:0ce1d6551e6e844dbdbc334916d33387981580d6 0x51a97 - libsvn_wc-1.so.0 -
:7258fe20e1dd7632c7df62804d62a93b5091b4c0 0x397d1 svn_sqlite__with_lock libsvn_subr-1.so.0 -
:0ce1d6551e6e844dbdbc334916d33387981580d6 0x5347d svn_wc_upgrade libsvn_wc-1.so.0 -
:a6d3e8a7f53c0575784fb5ba1446da595716c8b3 0x1938c svn_client_upgrade libsvn_client-1.so.0 -
:297d841696bd8186b117b13599d461343b385af8 0x187c4 - [pie] -
:297d841696bd8186b117b13599d461343b385af8 0x6e67 main [pie] -

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 24113                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       24113                24113                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

var_log_messages:
:Jun  4 17:12:44 ebony yum[1633]: Updated: xmlrpc-c-1.29.3-1703.svn2290.fc17.i686
:Jun  4 17:14:56 ebony yum[1633]: Updated: xmlrpc-c-client-1.29.3-1703.svn2290.fc17.i686
:Jun  4 17:30:03 ebony yum[1373]: Installed: notify-sharp-0.4.0-0.17.20100411svn.fc17.i686
:Jun  4 17:30:14 ebony yum[1373]: Installed: gnome-keyring-sharp-1.0.1-0.10.133722svn.fc17.i686
:Jun  4 18:46:44 ebony yum[13622]: Installed: mplayer-common-1.0-0.138.20120205svn.fc17.i686
:Jun  4 18:51:24 ebony yum[13622]: Installed: mplayer-1.0-0.138.20120205svn.fc17.i686
:Jun  6 16:11:41 ebony abrt[13560]: Saved core dump of pid 13559 (/usr/bin/svn) to /var/spool/abrt/ccpp-2012-06-06-16:11:41-13559 (1728512 bytes)
Comment 1 Gabriele Svelto 2012-06-06 10:27:43 EDT
Created attachment 589924 [details]
File: dso_list
Comment 2 Gabriele Svelto 2012-06-06 10:27:46 EDT
Created attachment 589925 [details]
File: maps
Comment 3 Gabriele Svelto 2012-06-06 10:27:52 EDT
Created attachment 589926 [details]
File: backtrace
Comment 4 Joe Orton 2012-06-06 10:37:14 EDT
Can you reproduce this with the 1.7.5 packages in updates-testing?

I tested with a random old 1.6.x checkout with 1.7.5 installed and it worked fine.
Comment 5 Gabriele Svelto 2012-06-06 10:54:34 EDT
I updated to subversion-1.7.5-1.fc17.i686 and the problem is gone, now subversion only prints out a warning message and exits with error code 1 instead of crashing.
Comment 6 Joe Orton 2012-06-06 11:48:18 EDT
There are certain cases which "svn upgrade" will not ever be able to handle.  In this case it looks like the state of the subtree was already modifed from the original checkout (maybe an "svn mv" or "svn cp"?).  Without the parent node the upgrade cannot be completed; I'd say you should try a new checkout.
Comment 7 Gabriele Svelto 2012-06-06 14:26:48 EDT
I didn't excpect 'svn upgrade' to succeed, the fact that I tried it on a directory that had been taken out of its original tree and had local modifications was an accident. Still I thought signaling the crash made sense as it shouldn't happen during normal operation, even if the checkout is incomplete.
Comment 8 Fedora End Of Life 2013-07-03 19:05:21 EDT
This message is a reminder that Fedora 17 is nearing its end of life.
Approximately 4 (four) weeks from now Fedora will stop maintaining
and issuing updates for Fedora 17. It is Fedora's policy to close all
bug reports from releases that are no longer maintained. At that time
this bug will be closed as WONTFIX if it remains open with a Fedora 
'version' of '17'.

Package Maintainer: If you wish for this bug to remain open because you
plan to fix it in a currently maintained version, simply change the 'version' 
to a later Fedora version prior to Fedora 17's end of life.

Bug Reporter:  Thank you for reporting this issue and we are sorry that 
we may not be able to fix it before Fedora 17 is end of life. If you 
would still like  to see this bug fixed and are able to reproduce it 
against a later version  of Fedora, you are encouraged  change the 
'version' to a later Fedora version prior to Fedora 17's end of life.

Although we aim to fix as many bugs as possible during every release's 
lifetime, sometimes those efforts are overtaken by events. Often a 
more recent Fedora release includes newer upstream software that fixes 
bugs or makes them obsolete.
Comment 9 Fedora End Of Life 2013-07-31 21:26:33 EDT
Fedora 17 changed to end-of-life (EOL) status on 2013-07-30. Fedora 17 is 
no longer maintained, which means that it will not receive any further 
security or bug fix updates. As a result we are closing this bug.

If you can reproduce this bug against a currently maintained version of 
Fedora please feel free to reopen this bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.