Bug 829356 - Transport options need better docs
Transport options need better docs
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: corosync (Show other bugs)
7.0
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Jan Friesse
Cluster QE
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 10:33 EDT by Jaroslav Kortus
Modified: 2012-06-07 03:03 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-06 10:59:07 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jaroslav Kortus 2012-06-06 10:33:27 EDT
Description of problem:
values for the transport option are not well described. The only possible options listed in man page are udp, updu and iba.

In cluster RNG (back in rhel6) the options are as follows:
udp (multicast default), udpb (broadcast), udpu (unicast) and rdma (Infiniband)

I'd like you to make sure the description in the man page is up to date.

Version-Release number of selected component (if applicable):
corosync-2.0.0-2.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. man corosync.conf (look for transport)
2.
3.
  
Actual results:
corosync-2.0.0-2.el7.x86_64

Expected results:
all options documented and matching current state

Additional info:
Comment 1 Jan Friesse 2012-06-06 10:59:07 EDT
Jardo,
corosync man page is up to date. Cluster RNG will go (because it's part of cman and that will go) and there will be corosync RNG. Only difference I see is udpb which is udp + broadcast (and internally by cman this is converted to broadcast: yes and transport: udp). Both udp and broadcast are documented and can be used without any problems by user.

I'm closing bug as notabug. If you will feel there should be some kind of additional info, please reopen bug.
Comment 2 Jaroslav Kortus 2012-06-06 12:52:16 EDT
Thanks for the explanation. The iba and rdma options are also "translated" in a similar way?
Comment 3 Jan Friesse 2012-06-07 03:03:27 EDT
rdma (in cman) = iba (in corosync). Plan (in corosync) is not use rdma, but rather directly iba (ibverbs) to achieve higher network throughput (iba should be like UDP, rdma is like TCP), but it's not sure if we will be able to finish such support in FC18 / RHEL 7 GA. But this is reason for different names in cman vs. corosync (cman describes real state (because of no future of it), corosync describes future (because it hopefully has some ;) ).

Note You need to log in before you can comment on or make changes to this bug.