Bug 82936 - Anti-aliasing of fonts doesn't work in KDE
Anti-aliasing of fonts doesn't work in KDE
Status: CLOSED DUPLICATE of bug 74974
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i686 Linux
high Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2003-01-28 12:38 EST by Need Real Name
Modified: 2006-02-21 13:51 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2006-02-21 13:51:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2003-01-28 12:38:15 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.7 [en] (X11; I; SunOS 5.8 sun4u)

Description of problem:
The following problem is being faced by me:

Anti-aliasing of fonts doesn't work in KDE. This works in GNOME but GNOME
applications using anti-aliased fonts especially gnome-terminal have a huge
memory leak. Using gnome-terminal for some amount of time, exhausted the whole
of my RAM and even the swap. With each line of output on the terminal, all my
memory got consumed (around 100 MB of main RAM + 500 MB of swap) and the system
got stuck after a period of time.

I also get the following error message on the console whenever I run any

Xlib: Extension RENDER missing on display 0:0

Running xdpyinfo also shows that extension RENDER is not available.

I have an Intel 845G graphics controller (part of Intel 845G chipset)
Almost all of my friends, who have a different graphics card, are not facing any
problem. Anti-aliasing works in KDE. There is no memory leak in gnome-terminal.
Also, we installed the same set of packages from the 8.0 CD and had all default
settings which come with 8.0

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Run X
2. Run gnome-terminal

Actual Results:  When gnome-terminal is run, slowly over a period of time the
amount of memory consumed by it goes on climbing (checked this by running ps
-aux | sort +3n) till all memory including swap get over and the system gets

Also anti-aliased fonts dont't work in KDE.

I also get this error 
Xlib: Extension RENDER missing on display 0:0 
for most of the programs that have a GUI

Expected Results:  Almost implied by the facts already stated.

Additional info:

Video card

Intel 82845G graphics controller
also called  Intel 845G  in-built graphics or Intel Extreme Graphics(part of
Intel 845G chipset)

All program versions are those that come as default with RedHat Linux 8.0
Comment 1 Mike A. Harris 2003-01-29 02:53:13 EST

*** This bug has been marked as a duplicate of 74974 ***
Comment 2 Red Hat Bugzilla 2006-02-21 13:51:27 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.