Bug 829378 - Poor error message when loading policy module
Summary: Poor error message when loading policy module
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: libsemanage
Version: 6.2
Hardware: All
OS: Linux
unspecified
low
Target Milestone: rc
: ---
Assignee: Daniel Walsh
QA Contact: Michal Trunecka
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-06-06 14:58 UTC by Moray.Henderson
Modified: 2014-09-30 23:33 UTC (History)
5 users (show)

Fixed In Version: libsemanage-2.0.43-4.2.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 10:54:41 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0465 normal SHIPPED_LIVE libsemanage bug fix update 2013-02-20 21:07:14 UTC

Description Moray.Henderson 2012-06-06 14:58:12 UTC
Description of problem:
Loading a custom SELinux policy module which worked on RHEL 5 gives unhelpful error in RHEL 6.  The actual cause was conflict with a file context rule new to RHEL 6.


Version-Release number of selected component (if applicable):
2.0.43-4.1.el6


How reproducible:
100%


Steps to Reproduce:
1.  Create new policy module with file context pattern that already exists in standard policy (e.g. /var/run/passenger(/.*)? )
2.  Try to load it.

  
Actual results:
# semodule -i mypolicy.pp
/etc/selinux/targeted/contexts/files/file_contexts: Invalid argument
libsemanage.semanage_install_active: setfiles returned error code 1. 
semodule:  Failed!


Expected results:
# semodule -i mypolicy.pp
File context already exists for /var/run/passenger: mypolicy.fc line 5
semodule:  Failed!

or similar message.


Additional info:
There is a reasonable error message in the Fedora 17 version:

# semodule -i mypol.pp
/etc/selinux/targeted/contexts/files/file_contexts: Multiple different specifications for /var/run/passenger(/.*)?
(system_u:object_r:passenger_var_run_t:s0 and system_u:object_r:var_run_t:s0).
/etc/selinux/targeted/contexts/files/file_contexts: Invalid argument
libsemanage.semanage_install_active: setfiles returned error code 1.
semodule:  Failed!

Would be nice to include the line number of mypol.fc which caused the error, but at least the Fedora 17 version of the message should be released into RHEL 6.2.

Comment 3 RHEL Product and Program Management 2012-07-10 08:39:16 UTC
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.

Comment 4 RHEL Product and Program Management 2012-07-10 23:50:22 UTC
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.

Comment 5 RHEL Product and Program Management 2012-08-14 22:00:35 UTC
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.

Comment 11 errata-xmlrpc 2013-02-21 10:54:41 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0465.html


Note You need to log in before you can comment on or make changes to this bug.