Bug 829385 - [RFE] Add fake_mname option
[RFE] Add fake_mname option
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: bind-dyndb-ldap (Show other bugs)
6.4
Unspecified Unspecified
medium Severity unspecified
: rc
: ---
Assigned To: Adam Tkac
Namita Soman
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 11:11 EDT by Dmitri Pal
Modified: 2013-11-21 15:02 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Feature: New fake_mname bind-dyndb-ldap option which allows to override master server name in SOA record. Reason: Without this option it was impossible to share one LDAP database between multiple master servers. Only one master server could be used. Result (if any): With this optiopn it is possible to override master server name in SOA record so multiple servers can act as master server for one LDAP database.
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 03:57:59 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dmitri Pal 2012-06-06 11:11:44 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/bind-dyndb-ldap/ticket/17

We should add an optional fake_mname option that would cause bind-dyndb-ldap to use the value of this option as mname for all queries it gets. We will basically pretend that the given server (most likely us) is the master for all the zones that we are serving.
Comment 1 RHEL Product and Program Management 2012-07-10 04:51:13 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 19:06:31 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 3 Jenny Galipeau 2012-07-13 10:37:46 EDT
Please add description and use cases for this new option
Comment 4 Petr Spacek 2012-07-16 04:05:17 EDT
It is documented in http://git.fedorahosted.org/git/?p=bind-dyndb-ldap.git;a=blob;f=README

Quote:
 fake_mname (default "")
         Ignore value of the idnsSOAmName (primary master DNS name) attribute
         and use this value instead. This allows multiple BIND processes to share
         one LDAP database and every BIND reports itself as a primary master in
         SOA record, for example.

Change "fake_mname" value in /etc/named.conf, reload named and try to dig SOA record to verify value seen by DNS clients.
Comment 5 Petr Spacek 2012-07-16 08:17:09 EDT
Worked example for existing zone "zone.example":

Zone is stored in LDAP object 'idnsname=zone.example,cn=dns,dc=e,dc=org'. It has attribute 'idnsSOAmName' with content 'ldap-value'.

Zone name is automatically added to fake_mname values without trailing period. If trailing period is present, value should be sent as is. (This applies to value in LDAP and value in /etc/named.conf in same way.)



1) Without fake_mname.
Delete fake_mname parameter from /etc/named.conf and reload named.

$ dig @127.0.0.1 -t SOA +multiline zone.example
;; ANSWER SECTION:
zone.example.		86400 IN SOA ldap-value.zone.example. nonexistent.zone.example. (

See column with text 'ldap-value.zone.example.'.



2) With fake_mname
Add fake_mname parameter to /etc/named.conf and reload named. Use the value 'override-value'.

$ dig @127.0.0.1 -t SOA +multiline zone.example
;; ANSWER SECTION:
zone.example.		86400 IN SOA override-value.zone.example. nonexistent.zone.example. (



3) With fake_mname and trailing period
Example for fake_mname value 'server.another-zone.example.':
$ dig @127.0.0.1 -t SOA +multiline zone.example
;; ANSWER SECTION:
zone.example.		86400 IN SOA server.another-zone.example. nonexistent.zone.example. (
Comment 12 Petr Spacek 2012-08-10 04:02:31 EDT
DNS dynamic updates are sent to "master" authoritative server, i.e. server declated in SOA mname field => all dynamic updates are sent to single server.

Fake_mname provides solution to this problem. It allows to announce more than one server as "master", i.e. distribute update requests across all servers.

Use case for this feature: To avoid single point of failure for dynamic updates.
Comment 13 Michael Gregg 2013-01-15 17:03:54 EST
verified against ipa-server-3.0.0-9.el6.x86_64

dig @127.0.0.1 -t SOA +multiline testrelm.com

;; ANSWER SECTION:
testrelm.com.           86400 IN SOA zippyvm4.testrelm.com. hostmaster.testrelm.com. (
Comment 15 errata-xmlrpc 2013-02-21 03:57:59 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0359.html

Note You need to log in before you can comment on or make changes to this bug.