Bug 829391 - [RFE] Define and use new attribute for default TTL value
[RFE] Define and use new attribute for default TTL value
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: bind-dyndb-ldap (Show other bugs)
7.1
All Linux
high Severity high
: rc
: ---
Assigned To: Pavel Picka
Namita Soman
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 11:14 EDT by Dmitri Pal
Modified: 2016-11-04 00:50 EDT (History)
9 users (show)

See Also:
Fixed In Version: bind-dyndb-ldap-10.0-1.el7
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-11-04 00:50:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cos-example.ldif (1.21 KB, text/plain)
2014-12-16 14:11 EST, Petr Spacek
no flags Details
evidence (8.60 KB, text/plain)
2016-08-19 03:45 EDT, Pavel Picka
no flags Details

  None (edit)
Description Dmitri Pal 2012-06-06 11:14:55 EDT
This bug is created as a clone of upstream ticket:
https://fedorahosted.org/bind-dyndb-ldap/ticket/70

Currently default TTL is hardcoded. Value in SOA is ignored.
Comment 1 RHEL Product and Program Management 2012-07-10 04:50:52 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 2 RHEL Product and Program Management 2012-07-10 19:06:58 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 7 Petr Spacek 2013-05-21 07:49:54 EDT
Bug summary was changed according to https://fedorahosted.org/bind-dyndb-ldap/ticket/70#comment:3.
Comment 10 Petr Spacek 2014-12-16 14:11:29 EST
Created attachment 969700 [details]
cos-example.ldif
Comment 11 Petr Spacek 2014-12-16 14:18:41 EST
Workaround for this deficiency is to use "Class of service" feature from RHDS:
https://access.redhat.com/documentation/en-US/Red_Hat_Directory_Server/8.2/html/Administration_Guide/Advanced_Entry_Management-Assigning_Class_of_Service.html#How_a_Pointer_CoS_Works-Figure_5_1Sample_Pointer_CoS

You have to create one 'template' entry (cn=default-ttl-value-definition) which holds default dnsTTL value. Then you have to add another entry (cn=default-ttl-cos-definition) which defines which attribute from which template should be used.

After that, RHDS will start returning dnsTTL attribute with default value (from template) for entries where no dnsTTL is defined explicitly.

Attachment cos-example.ldif contains complete working example.
Comment 15 Pavel Picka 2016-08-19 03:45 EDT
Created attachment 1192064 [details]
evidence

Verified

bind-dyndb-ldap - 10.0-4.el7.x86_64
Comment 17 errata-xmlrpc 2016-11-04 00:50:50 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2016-2375.html

Note You need to log in before you can comment on or make changes to this bug.