This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 829416 - F17 PXE installation using load_ramdisk and root=/dev/rd/0 fails
F17 PXE installation using load_ramdisk and root=/dev/rd/0 fails
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
17
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 12:25 EDT by Philippe Dax
Modified: 2013-01-10 01:49 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-07 12:49:51 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Philippe Dax 2012-06-06 12:25:43 EDT
Description of problem:

While booting by PXE to proceed to a network installation of F17 the control is given to dracut shell.

Version-Release number of selected component (if applicable):
Fedora 17

How reproducible:
Always

Steps to Reproduce:
1.boot with F12 key
2.choose Fedora 17 in the screen menu
3.
  
Actual results:
console output
vmlinuz
initrd ..... ready
...
...
...
dracut Warning: unable to process initqueue
dracut Warning:/dev/rd/0 does not exist

drpping to debug shell.

dracut:/#

Expected results:
installation process as it works with F16, F15, F14, F13, F12, F11

Additional info:
file f17.cfg

label f17
        menu label ^Install auto Fedora-17
        kernel ks/kernels/fedora/17/x86_64/vmlinuz
        append ksdevice=auto load_ramdisk=1 initrd=ks/kernels/fedora/17/x86_64/initrd.img repo=http://dl.fedoraproject.org/pub/fedora/linux/development/17/x86_64/os/ network ks=http://www.infres.enst.fr/admin/ks/install/fedora/17/x86_64/auto.cfg ip=dhcp ramdisk_size=3000 root=/dev/rd/0 DRACUT_QUIET=no rw --
Comment 1 Will Woods 2012-06-06 13:41:20 EDT
Wow, load_ramdisk is oooold. I didn't know anyone used ramdisks anymore..

The problem is "root=/dev/rd0" - if "root=" is specified, dracut ignores "repo=". And "repo=" is what dracut is trying to use to find the installer runtime image (which is the real root= device), so it can't find the installer, and you get dropped into the debug shell.

Try removing "root=/dev/rd0" and "load_ramdisk=1" and see if that works. You should probably remove "ramdisk_size=3000" as well. 

Also: "ksdevice=auto" is unnecessary, "rw" is the default, and I don't really know what "network" does - so you could probably remove those without hurting anything.

Your append line will probably look something like:

        append initrd=ks/kernels/fedora/17/x86_64/initrd.img repo=http://dl.fedoraproject.org/pub/fedora/linux/development/17/x86_64/os/ ks=http://www.infres.enst.fr/admin/ks/install/fedora/17/x86_64/auto.cfg ip=dhcp 

Does this make the system boot?
Comment 2 Philippe Dax 2012-06-07 06:08:02 EDT
Yes it works fine !
Thanks you very much

Note You need to log in before you can comment on or make changes to this bug.