Bug 829426 - Yum Plugin usability Improvements
Yum Plugin usability Improvements
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: subscription-manager (Show other bugs)
6.4
Unspecified Unspecified
urgent Severity unspecified
: rc
: ---
Assigned To: Michael Stead
Entitlement Bugs
: ZStream
Depends On: 818383
Blocks: 738066
  Show dependency treegraph
 
Reported: 2012-06-06 13:00 EDT by RHEL Product and Program Management
Modified: 2012-06-20 06:28 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-20 06:28:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description RHEL Product and Program Management 2012-06-06 13:00:30 EDT
This bug has been copied from bug #818383 and has been proposed
to be backported to 6.3 z-stream (EUS).
Comment 4 Michael Stead 2012-06-06 13:15:19 EDT
Fixed by Chris Duryee

61d499c5 RHEL6.3.z 0.99.19.2
Comment 6 John Sefler 2012-06-06 15:46:37 EDT
Using test procedures from https://bugzilla.redhat.com/show_bug.cgi?id=818383#c11 to verify version....

[root@jsefler-r63-server ~]# rpm -q subscription-manager
subscription-manager-0.99.19.2-1.el6_3.x86_64



Testing Case MSG1.............................................
If not registered to either next gen or classic: MSG1

[root@jsefler-r63-server ~]# subscription-manager unregister
This system is currently not registered.
[root@jsefler-r63-server ~]# rm /etc/sysconfig/rhn/systemid
rm: cannot remove `/etc/sysconfig/rhn/systemid': No such file or directory
[root@jsefler-r63-server ~]# yum repolist
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security,
              : subscription-manager
Updating certificate-based repositories.
Unable to read consumer identity

This machine has not been registered and therefore has
no access to security and other critical updates. Please
register using subscription-manager.

This system is not registered with RHN.
RHN Satellite or RHN Classic support will be disabled.
repolist: 0
[root@jsefler-r63-server ~]# 

^^^^ VERIFIED, MSG1 (from https://bugzilla.redhat.com/show_bug.cgi?id=818383#c2) is displayed from subscription-manager plugin as well as the corresponding rhnplugin message from RHN Classic.



Testing Case MSG2.............................................
If registered to nextgen, but no subscrptions have been consumed: MSG2

[root@jsefler-r63-server ~]# subscription-manager config --server.hostname subscription.rhn.stage.redhat.com
[root@jsefler-r63-server ~]# subscription-manager register --username stage_test_12
Password: 
The system has been registered with id: 2339f66a-9afb-477d-839e-e62691698fac 
[root@jsefler-r63-server ~]# yum repolist
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security,
              : subscription-manager
Updating certificate-based repositories.

This system has been registered to Red Hat Subscription
Management, but has no subscriptions applied. Please use
subscription-manager in order to enable access to security
and other critical updates.

This system is not registered with RHN.
RHN Satellite or RHN Classic support will be disabled.
repolist: 0
[root@jsefler-r63-server ~]# 

^^^^ VERIFIED, a modified MSG2 (from https://bugzilla.redhat.com/show_bug.cgi?id=818383#c2) is now displayed from subscription-manager plugin while the rhnplugin message continues to state that the system is not registered with RHN.



Testing Case MSG3.............................................
If registered and subscriptions have expired, MSG3

[root@jsefler-r63-server ~]# subscription-manager config --server.insecure=1
[root@jsefler-r63-server ~]# subscription-manager subscribe --auto
Installed Product Current Status:
Product Name:         	Red Hat Enterprise Linux Server
Status:               	Subscribed               

[root@jsefler-r63-server ~]# subscription-manager list --installed | grep Expires
Expires:              	04/26/2013               
[root@jsefler-r63-server ~]# date 050100002013Wed May  1 00:00:00 EDT 2013
[root@jsefler-r63-server ~]# yum repolistLoaded plugins: product-id, refresh-packagekit, rhnplugin, security,
              : subscription-manager
Updating certificate-based repositories.

This system has been registered to Red Hat Subscription
Management, but has no subscriptions applied. Please use
subscription-manager in order to enable access to security
and other critical updates.


*** WARNING ***
The subscription for following product(s) has expired:
  - Red Hat Developer Toolset (for RHEL Server)
  - Red Hat Enterprise Linux Server
You no longer have access to the repositories that
provide these products.  It is important that you apply an
active subscription in order to resume access to security
and other critical updates. If you don't have other active
subscriptions, you can renew the expired subscription.

This system is not registered with RHN.
RHN Satellite or RHN Classic support will be disabled.
repolist: 0
[root@jsefler-r63-server ~]# 

^^^^ VERIFIED, MSG3 (from https://bugzilla.redhat.com/show_bug.cgi?id=818383#c2) is displayed warning us of our expired subscriptions.  MSG1 (from https://bugzilla.redhat.com/show_bug.cgi?id=818383#c2) is also displayed and is true for this verification test.  Finally, the rhnplugin message continues to state that the system is not registered with RHN.



Testing Case MSG4.............................................
if there are subscirptions for next gen which are active: MSG4

[root@jsefler-r63-server ~]# date 060615372012Wed Jun  6 15:37:00 EDT 2012
[root@jsefler-r63-server ~]# subscription-manager list --installed
+-------------------------------------------+
    Installed Product Status
+-------------------------------------------+
Product Name:         	Red Hat Enterprise Linux Server
Product ID:           	69                       
Version:              	6.3                      
Arch:                 	x86_64                   
Status:               	Subscribed               
Starts:               	04/27/2012               
Expires:              	04/26/2013               

[root@jsefler-r63-server ~]# yum repolist
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security,
              : subscription-manager
Updating certificate-based repositories.

Please use yum-config-manager to configure which software
repositories are used with Red Hat Subscription Management.

This system is not registered with RHN.
RHN Satellite or RHN Classic support will be disabled.
repo id                       repo name                                status
rhel-6-server-cf-tools-1-rpms Red Hat CloudForms Tools for RHEL 6 (RPM    25
rhel-6-server-rpms            Red Hat Enterprise Linux 6 Server (RPMs) 7,262
rhel-server-dts-6-rpms        Red Hat Developer Toolset RPMs for Red H     0
repolist: 7,287
[root@jsefler-r63-server ~]# 

^^^^ VERIFIED, A modified MSG4 (from https://bugzilla.redhat.com/show_bug.cgi?id=818383#c2) is now displayed from subscription-manager plugin while the rhnplugin message continues to state that the system is not registered with RHN.



Testing Case no-MSG.............................................
If registered to classic, log nothing.

[root@jsefler-r63-server ~]# rhnreg_ks --serverUrl=https://xmlrpc.rhn.code.stage.redhat.com/XMLRPC --username=qa@redhat.com --password ***** --force --norhnsd --nohardware --nopackages --novirtinfo
[root@jsefler-r63-server ~]# yum repolist
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security,
              : subscription-manager
Updating certificate-based repositories.
repo id                       repo name                                status
rhel-6-server-cf-tools-1-rpms Red Hat CloudForms Tools for RHEL 6 (RPM    25
rhel-6-server-rpms            Red Hat Enterprise Linux 6 Server (RPMs) 7,262
rhel-server-dts-6-rpms        Red Hat Developer Toolset RPMs for Red H     0
rhel-x86_64-server-6          Red Hat Enterprise Linux Server (v. 6 fo 6,733
repolist: 14,020
[root@jsefler-r63-server ~]# subscription-manager list --installed | grep Expires
Expires:              	04/26/2013               
[root@jsefler-r63-server ~]# date 050100002013
Wed May  1 00:00:00 EDT 2013
[root@jsefler-r63-server ~]# yum repolist
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security,
              : subscription-manager
Updating certificate-based repositories.
rhel-x86_64-server-6                                  | 1.6 kB     00:00     
repo id              repo name                                         status
rhel-x86_64-server-6 Red Hat Enterprise Linux Server (v. 6 for 64-bit  6,733
repolist: 6,733
[root@jsefler-r63-server ~]# date 060615422012
Wed Jun  6 15:42:00 EDT 2012
[root@jsefler-r63-server ~]# subscription-manager list --consumed | grep Serial
Serial Number:        	1633187484875863819      
Serial Number:        	1633187484875863819      
[root@jsefler-r63-server ~]# subscription-manager unsubscribe --serial=1633187484875863819
[root@jsefler-r63-server ~]# yum repolistLoaded plugins: product-id, refresh-packagekit, rhnplugin, security,
              : subscription-manager
Updating certificate-based repositories.
repo id              repo name                                         status
rhel-x86_64-server-6 Red Hat Enterprise Linux Server (v. 6 for 64-bit  6,733
repolist: 6,733
[root@jsefler-r63-server ~]# subscription-manager unregister
System has been un-registered.
[root@jsefler-r63-server ~]# yum repolist
Loaded plugins: product-id, refresh-packagekit, rhnplugin, security,
              : subscription-manager
Updating certificate-based repositories.
Unable to read consumer identity
repo id              repo name                                         status
rhel-x86_64-server-6 Red Hat Enterprise Linux Server (v. 6 for 64-bit  6,733
repolist: 6,733
[root@jsefler-r63-server ~]# 

^^^^ VERIFIED, When registered with RHN classically, the subscription-manager yum plugin did not print MSG1 MSG2 MSG3 or MSG4. 


Moving to VERIFIED
Comment 8 errata-xmlrpc 2012-06-20 06:28:39 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1008.html

Note You need to log in before you can comment on or make changes to this bug.