Bug 829435 - [ipa webui] Adding a Service Category for an HBAC rule is case-sensitive
[ipa webui] Adding a Service Category for an HBAC rule is case-sensitive
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: ipa (Show other bugs)
7.0
Unspecified Unspecified
unspecified Severity low
: rc
: ---
Assigned To: Martin Kosek
IDM QE LIST
:
: 830912 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 14:08 EDT by Namita Soman
Modified: 2015-01-16 09:50 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-01-16 09:48:07 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Namita Soman 2012-06-06 14:08:11 EDT
Description of problem:
Add the existing hbac service group 'Sudo' to a hbac rule. and it gets added as 'sudo'. This lists 'Sudo' in the 'Add' window. If selected, it will throw error as expected - that this entry already exists. But this is inconsistent with other 'Add' windows which do not list objects already added.

Also: when a hostgroup, or usergroup is added, the user or host 'Add' window doesn't list members of groups already added. But Servicegroups and service doesn't behave like that. 

Version-Release number of selected component (if applicable):
ipa-server-2.2.0-16.el6.x86_64

How reproducible:
always

Steps to Reproduce:
1. Add 'Sudo' hbac service group
2. Add service
3. Click Add to add more service groups
  
Actual results:
2-> sudo services that are members of the Sudo Service group, are still listed
3 -> 'Sudo' is still listed as a group to add

Expected results:
2 -> sudo service group members should not be listed
3 -> Sudo should not be listed

Additional info:
Comment 2 Dmitri Pal 2012-06-08 13:16:56 EDT
Upstream ticket:
https://fedorahosted.org/freeipa/ticket/2823
Comment 6 Martin Kosek 2015-01-16 09:48:07 EST
With IdM/FreeIPA 4.1 PatternFly Web UI refactoring (Bug 1108212) and other changes, this is no longer an issue. Sudo service group is properly added and displayed.

Sudo is even no longer offered in the adding box as it is already added in the list. Closing the bug, feel free to reopen of you are still experiencing this bug.
Comment 7 Martin Kosek 2015-01-16 09:50:12 EST
*** Bug 830912 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.