Bug 829465 - SELinux is preventing /usr/bin/python2.7 from 'getattr' accesses on the file /etc/selinux/targeted/policy/policy.27.
SELinux is preventing /usr/bin/python2.7 from 'getattr' accesses on the file ...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:074398c5c1e2bb3dc469ab5290b...
:
: 829152 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 16:45 EDT by Devon Janitz
Modified: 2012-06-16 20:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-16 20:03:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Devon Janitz 2012-06-06 16:45:41 EDT
libreport version: 2.0.10
executable:     /usr/bin/python2.7
hashmarkername: setroubleshoot
kernel:         3.3.7-1.fc17.x86_64
time:           Wed 06 Jun 2012 04:45:27 PM EDT

description:
:SELinux is preventing /usr/bin/python2.7 from 'getattr' accesses on the file /etc/selinux/targeted/policy/policy.27.
:
:*****  Plugin catchall (100. confidence) suggests  ***************************
:
:If you believe that python2.7 should be allowed getattr access on the policy.27 file by default.
:Then you should report this as a bug.
:You can generate a local policy module to allow this access.
:Do
:allow this access for now by executing:
:# grep sealert /var/log/audit/audit.log | audit2allow -M mypol
:# semodule -i mypol.pp
:
:Additional Information:
:Source Context                system_u:system_r:setroubleshoot_fixit_t:s0-s0:c0.
:                              c1023
:Target Context                system_u:object_r:semanage_store_t:s0
:Target Objects                /etc/selinux/targeted/policy/policy.27 [ file ]
:Source                        sealert
:Source Path                   /usr/bin/python2.7
:Port                          <Unknown>
:Host                          (removed)
:Source RPM Packages           python-2.7.3-6.fc17.x86_64
:Target RPM Packages           selinux-policy-targeted-3.10.0-128.fc17.noarch
:Policy RPM                    selinux-policy-3.10.0-128.fc17.noarch
:Selinux Enabled               True
:Policy Type                   targeted
:Enforcing Mode                Permissive
:Host Name                     (removed)
:Platform                      Linux (removed) 3.3.7-1.fc17.x86_64 #1 SMP Mon
:                              May 21 22:32:19 UTC 2012 x86_64 x86_64
:Alert Count                   1
:First Seen                    Wed 06 Jun 2012 04:43:51 PM EDT
:Last Seen                     Wed 06 Jun 2012 04:43:51 PM EDT
:Local ID                      e8848060-1217-483b-8e89-96943add6f6b
:
:Raw Audit Messages
:type=AVC msg=audit(1339015431.913:111): avc:  denied  { getattr } for  pid=3293 comm="sealert" path="/etc/selinux/targeted/policy/policy.27" dev="dm-1" ino=2493110 scontext=system_u:system_r:setroubleshoot_fixit_t:s0-s0:c0.c1023 tcontext=system_u:object_r:semanage_store_t:s0 tclass=file
:
:
:type=SYSCALL msg=audit(1339015431.913:111): arch=x86_64 syscall=stat success=yes exit=0 a0=27df9d0 a1=7fff6c391ee0 a2=7fff6c391ee0 a3=27 items=0 ppid=3292 pid=3293 auid=4294967295 uid=0 gid=0 euid=0 suid=0 fsuid=0 egid=0 sgid=0 fsgid=0 tty=(none) ses=4294967295 comm=sealert exe=/usr/bin/python2.7 subj=system_u:system_r:setroubleshoot_fixit_t:s0-s0:c0.c1023 key=(null)
:
:Hash: sealert,setroubleshoot_fixit_t,semanage_store_t,file,getattr
:
:audit2allowunable to open /sys/fs/selinux/policy:  Permission denied
:
:
:audit2allow -Runable to open /sys/fs/selinux/policy:  Permission denied
:
:
Comment 1 Devon Janitz 2012-06-07 09:25:41 EDT
Happens every time I restart and loggin.
Comment 2 Daniel Walsh 2012-06-07 11:28:19 EDT
Did you click on the fix it button and then this AVC showed up?
Comment 3 Daniel Walsh 2012-06-07 11:39:25 EDT
Fixed in selinux-policy-3.10.0-129.fc17
Comment 4 Devon Janitz 2012-06-07 12:48:51 EDT
No.  I had just left it broke so I could see what else it may be affecting.
Comment 5 Daniel Walsh 2012-06-07 14:55:06 EDT
*** Bug 829152 has been marked as a duplicate of this bug. ***
Comment 6 Fedora Update System 2012-06-11 17:01:06 EDT
selinux-policy-3.10.0-130.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/selinux-policy-3.10.0-130.fc17
Comment 7 Fedora Update System 2012-06-15 19:58:28 EDT
Package selinux-policy-3.10.0-130.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing selinux-policy-3.10.0-130.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-9520/selinux-policy-3.10.0-130.fc17
then log in and leave karma (feedback).
Comment 8 Fedora Update System 2012-06-16 20:03:24 EDT
selinux-policy-3.10.0-130.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.