Bug 829487 - ypbind will not bind if network is off
ypbind will not bind if network is off
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: ypbind (Show other bugs)
6.2
Unspecified Unspecified
medium Severity medium
: rc
: ---
Assigned To: Honza Horak
Jakub Prokes
: Patch
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-06 17:22 EDT by Konstantin Olchanski
Modified: 2015-07-22 02:44 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: localhost not defined in domains causing need of the network when using it. Consequence: ypbind does not bind to ypserv on localhost when network is off Fix: Added check for localhost Result: ypbind works even if network is off
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-07-22 02:44:27 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
patch consulted with upstream (3.37 KB, patch)
2012-07-09 07:33 EDT, Honza Horak
no flags Details | Diff
patch consulted with upstream (3.40 KB, patch)
2012-07-10 04:38 EDT, Honza Horak
no flags Details | Diff

  None (edit)
Description Konstantin Olchanski 2012-06-06 17:22:07 EDT
ypbind does not bind to ypserv on localhost (same machine) if NetworkManager thinks that the network is off. This is surprising behaviour. One solution is use "ypbind -no-dbus", then ypbind binds to local ypserv correctly and NIS works as expected. Perhaps this should be the default configuration, matching the traditional UNIX behaviour of NIS tools.

ypbind-1.20.4-29.el6.x86_64

K.O.
Comment 2 Honza Horak 2012-07-09 07:33:32 EDT
Created attachment 597046 [details]
patch consulted with upstream

With this patch ypbind won't go offline when one of the servers is localhost.
Comment 3 Konstantin Olchanski 2012-07-09 13:48:42 EDT
I happened to look at the patch. The check is for IP address 127.0.0.1, correct for typical use, but remember than all 127.x.y.z IP addresses are localhost. K.O.
Comment 4 Honza Horak 2012-07-10 04:38:11 EDT
Created attachment 597245 [details]
patch consulted with upstream

(In reply to comment #3)
> I happened to look at the patch. The check is for IP address 127.0.0.1,
> correct for typical use, but remember than all 127.x.y.z IP addresses are
> localhost. K.O.

Thanks for pointing to that, enhanced patch is attached.
Comment 5 RHEL Product and Program Management 2013-10-13 20:37:20 EDT
This request was evaluated by Red Hat Product Management for
inclusion in the current release of Red Hat Enterprise Linux.
Because the affected component is not scheduled to be updated
in the current release, Red Hat is unable to address this
request at this time.

Red Hat invites you to ask your support representative to
propose this request, if appropriate, in the next release of
Red Hat Enterprise Linux.
Comment 6 Honza Horak 2015-02-19 09:22:00 EST
How to reproduce:
1. configure ypbind to bind to localhost
2. turn off all networks in NetworkManager except localhost
3. service ypbind start
4. echo $?

Actual results:
1
ypbind doesn't work

Expected results:
0
ypbind works
Comment 13 errata-xmlrpc 2015-07-22 02:44:27 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-1332.html

Note You need to log in before you can comment on or make changes to this bug.