Bug 829499 - NetworkManager tries to enable an interface only once
NetworkManager tries to enable an interface only once
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: NetworkManager (Show other bugs)
6.2
All Linux
high Severity high
: rc
: ---
Assigned To: Dan Williams
Desktop QE
: OtherQA, Patch
Depends On:
Blocks: 782183
  Show dependency treegraph
 
Reported: 2012-06-06 18:06 EDT by Konstantin Olchanski
Modified: 2013-02-21 05:34 EST (History)
4 users (show)

See Also:
Fixed In Version: NetworkManager-0.8.1-37.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-02-21 05:34:47 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
[PATCH] retry auto-connection 3 more times when it fails and again in 5 minute intervals (11.39 KB, patch)
2012-06-12 06:13 EDT, Jirka Klimes
no flags Details | Diff


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 284043 None None None Never

  None (edit)
Description Konstantin Olchanski 2012-06-06 18:06:14 EDT
After a network outage, NetworkManager-managed 6.2 machines lost their IP addresses and required manual operator intervention to restart the network.

This is surprising as 4.x and 5.x machines (before the NetworkManager) did not lose their IP addresses during similar network outages and continued to operate normally after network connectivity was restored.

This is the network diagram:
MYHOST---SWITCH1----SWITCH2---DHCPSERVER

This is what happened:

- power was lost on SWITCH1 and SWITCH2
- NetworkManager detected link loss and disabled the network on MYHOST (as expected)
- power was restored on SWITCH1
- NetworkManager detected link presence, tried to acquire an IP address (with a 45 sec timeout) (as expected)
- since SWITCH2 was still down, there was no DHCP reply
- after the 45 sec timeout, NetworkManager disabled the interface, there was no further NetworkManager activity afterwards (wrong - expected the NetworkManager to try several times, if not forever, before giving up)
- power was restored to SWITCH2, but the NetworkManager on MYHOST cannot see this

Before suggesting that all network switches should have UPS power and should never ever be shutdown, consider the case of scheduled maintenance and power outages where *I* cannot control the order in which the switches are powered back up or reconnected.

Is it possible to configure the NetworkManager was a longer timeout? With an option to try again after 30 min or after 1 hour?

NetworkManager-0.8.1-15.el6.x86_64
K.O.
Comment 2 Jirka Klimes 2012-06-12 06:13:49 EDT
Created attachment 591159 [details]
[PATCH] retry auto-connection 3 more times when it fails and again in 5 minute intervals

The patch implements automatic connection retries (first attempt + 3 retries) when auto-activation failed. And, then it tries again 4 times after 5 minutes.

It is basically a re-implementation of the feature present in NM upstream master branch for RHEL 6.
Comment 3 RHEL Product and Program Management 2012-07-10 04:42:21 EDT
This request was not resolved in time for the current release.
Red Hat invites you to ask your support representative to
propose this request, if still desired, for consideration in
the next release of Red Hat Enterprise Linux.
Comment 4 RHEL Product and Program Management 2012-07-10 20:04:12 EDT
This request was erroneously removed from consideration in Red Hat Enterprise Linux 6.4, which is currently under development.  This request will be evaluated for inclusion in Red Hat Enterprise Linux 6.4.
Comment 6 RHEL Product and Program Management 2012-10-03 17:30:58 EDT
This request was evaluated by Red Hat Product Management for
inclusion in a Red Hat Enterprise Linux release.  Product
Management has requested further review of this request by
Red Hat Engineering, for potential inclusion in a Red Hat
Enterprise Linux release for currently deployed products.
This request is not yet committed for inclusion in a release.
Comment 11 Tomas Pelka 2013-01-29 05:02:35 EST
Dear reporter,

could we ask you to retest in case you have access to newest NetworkManager?

Thanks in advance
Tom
Comment 12 Konstantin Olchanski 2013-01-29 13:20:31 EST
(In reply to comment #11)
> 
> could we ask you to retest in case you have access to newest NetworkManager?
> 

I am happy to retest, but you have to specify which "newest" NetworkManager you want me to test (and if it's a RH private test RPM, make it available for my download - you can send the secret URL to my email. I will not share the RPM file with anybody.) olchansk@panix.com, olchansk@triumf.ca

K.O.
Comment 13 Tomas Pelka 2013-01-30 04:39:52 EST
(In reply to comment #12)
> (In reply to comment #11)
> > 
> > could we ask you to retest in case you have access to newest NetworkManager?
> > 
> 
> I am happy to retest, but you have to specify which "newest" NetworkManager
> you want me to test (and if it's a RH private test RPM, make it available
> for my download - you can send the secret URL to my email. I will not share
> the RPM file with anybody.) olchansk@panix.com, olchansk@triumf.ca
> 
> K.O.

NetworkManager-0.8.1-39.el6 is available via RHN rhel-x86_64-server-6-beta (or client/workstation/... depends on your rhel variant) channel.

More info at https://rhn.redhat.com/rhn/software/channels/Beta.do

Or the direct link [1] to download via web UI might work as well.

[1] https://rhn.redhat.com/rhn/software/packages/details/Overview.do?pid=741453
Comment 14 errata-xmlrpc 2013-02-21 05:34:47 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0429.html

Note You need to log in before you can comment on or make changes to this bug.