Bug 829502 - the module needs to ensure that when it's built against 389-ds-base 1.2.10 or later, to not have transaction support
Summary: the module needs to ensure that when it's built against 389-ds-base 1.2.10 or...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 6
Classification: Red Hat
Component: slapi-nis
Version: 6.2
Hardware: Unspecified
OS: Unspecified
medium
urgent
Target Milestone: rc
: ---
Assignee: Nalin Dahyabhai
QA Contact: Namita Soman
URL:
Whiteboard:
Depends On:
Blocks: 830206
TreeView+ depends on / blocked
 
Reported: 2012-06-06 22:40 UTC by Nalin Dahyabhai
Modified: 2013-02-21 09:50 UTC (History)
5 users (show)

Fixed In Version: slapi-nis-0.40-3.el6
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2013-02-21 09:50:05 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2013:0370 0 normal SHIPPED_LIVE slapi-nis bug fix update 2013-02-20 20:52:36 UTC

Description Nalin Dahyabhai 2012-06-06 22:40:06 UTC
Description of problem:
While slapi-nis supports working with the directory server's backend transaction scheme, it does so by checking at build-time if the server supports them.  At the time we built slapi-nis-0.40-1.el6, we built it against 389-ds-base-1.2.9.14-1.el6_2.2, so transaction support was not built in.

We need to add explicit versioned build and install-time dependencies to the package, and then recompile it.

Version-Release number of selected component (if applicable):
slapi-nis-0.40-1.el6

Comment 6 Nalin Dahyabhai 2012-07-17 15:43:16 UTC
The strategy which directory server will be taking for transaction support changed since transaction support was added to the plugin -- the new strategy assumes that plugins remain unaware of transactions, so we actually need to ensure that support in the plugin for transactions is either disabled or excised.

Comment 9 Namita Soman 2012-11-28 15:49:31 UTC
lowering priority - it was already verified in 6.3 but had to be committed to both branches (6.4)

Comment 10 Namita Soman 2013-01-24 17:35:37 UTC
Ran regression tests for IPA. No issues found. Marking this verified - Sanity only

Comment 12 errata-xmlrpc 2013-02-21 09:50:05 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-0370.html


Note You need to log in before you can comment on or make changes to this bug.