Bug 829673 - VDSM: No handling for creating a brick in a directory that doesn't exist
VDSM: No handling for creating a brick in a directory that doesn't exist
Status: CLOSED WONTFIX
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: rhsc (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: Shireesh
Sudhir D
gluster, storage
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 05:12 EDT by Daniel Paikov
Modified: 2013-07-03 02:06 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-15 04:12:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
engine.log (54.96 KB, application/x-compressed-tar)
2012-06-07 05:12 EDT, Daniel Paikov
no flags Details
vdsm.log (624.98 KB, application/x-compressed-tar)
2012-06-07 05:13 EDT, Daniel Paikov
no flags Details

  None (edit)
Description Daniel Paikov 2012-06-07 05:12:23 EDT
Created attachment 590139 [details]
engine.log

When trying to create a brick in a sub-directory of a directory that doesn't exist, the brick creation fails. For example, try to create a brick in /dir1/dir2 while /dir1 doesn't exist.
Comment 1 Daniel Paikov 2012-06-07 05:13:03 EDT
Created attachment 590140 [details]
vdsm.log
Comment 3 Shireesh 2012-06-07 08:20:37 EDT
This is the behavior of GlusterFS, and user is expected to create appropriate brick directories before issuing the command. GlusterFS creates only the leaf level directories if required.

This will be documented in the current release. In the long term, we plan to provide a GUI where user selects disks / partitions in which the bricks are to be created, and in that case, the system will take care of creating appropriate directories before invoking the gluster command.
Comment 4 Shireesh 2012-06-15 04:12:06 EDT
Since there is no response to above comment for quite some time, I assume that the explanation is acceptable.

Note You need to log in before you can comment on or make changes to this bug.