Bug 829675 - GlusterFS: Can't remove and re-add the same brick
GlusterFS: Can't remove and re-add the same brick
Status: CLOSED DUPLICATE of bug 812214
Product: Red Hat Gluster Storage
Classification: Red Hat
Component: glusterd (Show other bugs)
unspecified
Unspecified Unspecified
medium Severity medium
: ---
: ---
Assigned To: krishnan parthasarathi
Sudhir D
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 05:21 EDT by Daniel Paikov
Modified: 2015-11-03 18:04 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-11 03:17:10 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
vdsm.log (599.94 KB, application/x-compressed-tar)
2012-06-07 05:21 EDT, Daniel Paikov
no flags Details
glusterfs log (5.30 KB, application/x-compressed-tar)
2012-06-07 05:23 EDT, Daniel Paikov
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 135343 None None None 2012-06-07 08:49:08 EDT

  None (edit)
Description Daniel Paikov 2012-06-07 05:21:20 EDT
Created attachment 590141 [details]
vdsm.log

* Create a brick on host:/dir
* Remove the brick
* Try to create the same brick
* 2nd create fails because the brick already exists, even though the brick was removed and doesn't appear in "gluster volume info".
Comment 1 Daniel Paikov 2012-06-07 05:23:09 EDT
Created attachment 590142 [details]
glusterfs log
Comment 3 Niels de Vos 2012-06-07 08:49:08 EDT
There are some procedures explained in https://access.redhat.com/knowledge/solutions/135343 that can help.

The (depending on view point) bug here, is that there are still some extended attributes set on the directory of the brick. After removing these, you should be able to re-use the existing brick.
Comment 4 Niels de Vos 2012-06-07 10:17:01 EDT
Bug 765572 mentions that a script can be used to remove the xattrs.

A description of it's usage can be found here:
- http://review.gluster.com/781
Comment 5 Niels de Vos 2012-06-11 03:17:10 EDT
Bug 812214#c10 contains a description about this problem as well. Closing this as a duplicate.

*** This bug has been marked as a duplicate of bug 812214 ***

Note You need to log in before you can comment on or make changes to this bug.