Bug 829685 - When you quickly click on 'Load 25 more' multiple times, the loaded package count exceeds the total count.
When you quickly click on 'Load 25 more' multiple times, the loaded package c...
Status: CLOSED WONTFIX
Product: Red Hat Satellite 6
Classification: Red Hat
Component: WebUI (Show other bugs)
6.0.0
Unspecified Linux
medium Severity medium (vote)
: Unspecified
: --
Assigned To: Partha Aji
Katello QA List
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 06:14 EDT by Sachin Ghai
Modified: 2014-03-18 13:37 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-03-18 13:37:37 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Loaded package count exceeds the total count (42.30 KB, image/png)
2012-06-07 06:16 EDT, Sachin Ghai
no flags Details

  None (edit)
Description Sachin Ghai 2012-06-07 06:14:03 EDT
Description of problem:

I registered a system and trying load the packages on UI. I started loading the packages by clicking on "Load 25 more" option. Initially 25 packages were loaded from total of 599 packages. 

Now if you slowly keep on loading the count by slowly clicking 'load 25 more', UI says "Loaded 600 of 599 total".

Now if you quickly click on 'Load 25 more' multiple times in one go, the count exceed the total count, like in my case its showing 625 of 599

Version-Release number of selected component (if applicable):
katello-cli-common-0.1.108-1.el6_3.noarch
katello-0.1.313-1.el6_3.noarch
katello-cli-0.1.108-1.el6_3.noarch


How reproducible:
always

Steps to Reproduce:
1. Register a system 

2. Go to systems --> right pane under "Packages"  keep on loading the packages quickly by clicking 'Load 25 more' multiple times and check the count

3.
  
Actual results:
Count shouldn't exceed the total limit

Expected results:
Count shouldn't exceed the total limit

Additional info:

Its reproducible only when you quickly click multiples time on 'Load 25 more'
Comment 1 Sachin Ghai 2012-06-07 06:15:09 EDT
(In reply to comment #0)

> Actual results:
> Count shouldn't exceed the total limit
> 
Load count exceeds the total count
Comment 2 Sachin Ghai 2012-06-07 06:16:42 EDT
Created attachment 590149 [details]
Loaded package count exceeds the total count
Comment 3 Sachin Ghai 2012-07-18 08:35:38 EDT
This issue is reproducible with following katello build too:

katello-0.2.44-1.git.73.3737e93.el6_3.noarch
Comment 4 Mike McCune 2014-03-18 13:37:37 EDT
This bug was closed because of a lack of activity.  If you feel this bug should be reconsidered for attention please feel free to re-open the bug with a comment stating why it should be reconsidered.

Note You need to log in before you can comment on or make changes to this bug.