Bug 829722 - re-registering a client that is in a system group seems to fail, but leaves the deleted systems in the system group
re-registering a client that is in a system group seems to fail, but leaves t...
Status: CLOSED DUPLICATE of bug 746765
Product: Katello
Classification: Community
Component: WebUI (Show other bugs)
1.0
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jason E. Rist
Katello QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-06-07 08:17 EDT by Ade Bradshaw
Modified: 2013-02-26 23:17 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-13 17:58:01 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
The outpiut of katello-debug (4.24 MB, application/x-gzip)
2012-06-07 08:17 EDT, Ade Bradshaw
no flags Details

  None (edit)
Description Ade Bradshaw 2012-06-07 08:17:57 EDT
Created attachment 590181 [details]
The outpiut of katello-debug

Description of problem:

I have two Fedora17 clients registered to a Katello instance (running in Fedora16). Both systems were in a system group. I tried to re-register them with a new activation key but the process failed with 

"Name has already been taken"  

The systems were removed from the interface and couldnt be added back in with the same names (adding them with new names works). 

I noticed that the system group still have entries for these two systems


Version-Release number of selected component (if applicable):
katello-glue-pulp-0.2.40-1.fc16.noarch
katello-candlepin-cert-key-pair-1.0-1.noarch
katello-glue-candlepin-0.2.40-1.fc16.noarch
katello-glue-foreman-0.2.40-1.fc16.noarch
katello-cli-0.2.39-1.fc16.noarch
katello-selinux-0.2.5-1.fc16.noarch
katello-repos-0.2.4-1.fc16.noarch
katello-certs-tools-1.1.6-1.fc16.noarch
katello-all-0.2.40-1.fc16.noarch
katello-qpid-client-key-pair-1.0-1.noarch
katello-common-0.2.40-1.fc16.noarch
katello-cli-common-0.2.39-1.fc16.noarch
katello-0.2.40-1.fc16.noarch
katello-configure-0.2.25-1.fc16.noarch
katello-qpid-broker-key-pair-1.0-1.noarch


How reproducible:


Steps to Reproduce:
1. Register a system
2. add it to a system group
3. Re-register the system
  
Actual results:
System cant be re-added but is removed from the interface

Expected results:
The system to be re-registered with the same name

Additional info:
Comment 1 Brad Buckingham 2012-06-13 17:58:01 EDT
After investigation, this issue appears to be related to an existing bugzilla; therefore, I am going to mark this one as a 'duplicate' of bug 746765.

The following is the scenario that I ran:

1. create a system group : group1
2. register a system to the dev env
   subscription-manager register --username admin --password admin --org ACME_Corporation --environment dev
3. add the system to system group1
4. attempt to register the system again using the --force option
   subscription-manager register --username admin --password admin --org ACME_Corporation --environment dev --force

After #4, observed the following:

on the client system:
Validation failed: Name has already been taken

on the server:
System no longer shown on the Systems page
Record for the system does exist in the systems table
Record for the system_group join does exist in the system_system_groups table
Candlepin no longer has knowledge of the system (consumer).

*** This bug has been marked as a duplicate of bug 746765 ***

Note You need to log in before you can comment on or make changes to this bug.